aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-18 11:12:17 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-18 22:12:46 +0200
commitcd02bf8e6cfcba287b8310f03edbafc6c6711ee2 (patch)
treea63c4833639276cf9e773f0228e2d154d2106599 /recipes/efl1
parent7681d358b2df532d44e26f6d4a7301d8d8f2d582 (diff)
downloadopenembedded-cd02bf8e6cfcba287b8310f03edbafc6c6711ee2.tar.gz
efl1 : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/ecore/add-tslib-support.patch104
-rw-r--r--recipes/efl1/ecore/fix-directfb-include.patch13
-rw-r--r--recipes/efl1/imlib2/remove-local-includes-20080421.patch15
3 files changed, 0 insertions, 132 deletions
diff --git a/recipes/efl1/ecore/add-tslib-support.patch b/recipes/efl1/ecore/add-tslib-support.patch
deleted file mode 100644
index c125122a91..0000000000
--- a/recipes/efl1/ecore/add-tslib-support.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-
-#
-# tslib support for ecore, (C) Michael 'Mickey' Lauer <mickey@Vanille.de>
-#
-
---- ecore/src/lib/ecore_fb/ecore_fb.c~add-tslib-support.patch
-+++ ecore/src/lib/ecore_fb/ecore_fb.c
-@@ -4,6 +4,13 @@
- #include "Ecore_Fb.h"
- #include "ecore_private.h"
-
-+
-+#ifdef HAVE_TSLIB
-+#include <tslib.h>
-+#include <errno.h>
-+#endif
-+
-+
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-@@ -77,6 +84,11 @@
- unsigned char z;
- };
-
-+#ifdef HAVE_TSLIB
-+struct tsdev *_ecore_fb_tslib_tsdev = NULL;
-+struct ts_sample _ecore_fb_tslib_event;
-+#endif
-+
- static void _ecore_fb_size_get(int *w, int *h);
- static int _ecore_fb_ts_fd_handler(void *data, Ecore_Fd_Handler *fd_handler);
- static int _ecore_fb_kbd_fd_handler(void *data, Ecore_Fd_Handler *fd_handler);
-@@ -269,10 +281,39 @@
- ecore_fb_init(const char *name __UNUSED__)
- {
- int prev_flags;
-+#ifdef HAVE_TSLIB
-+ char *tslib_tsdevice = NULL;
-+#endif
-
- _ecore_fb_init_count++;
- if (_ecore_fb_init_count > 1) return _ecore_fb_init_count;
-+#ifdef HAVE_TSLIB
-+ if ( ( tslib_tsdevice = getenv("TSLIB_TSDEVICE") ) != NULL )
-+ {
-+ printf( "ECORE_FB: TSLIB_TSDEVICE = '%s'\n", tslib_tsdevice );
-+ _ecore_fb_tslib_tsdev = ts_open( tslib_tsdevice, 1 ); /* 1 = nonblocking, 0 = blocking */
-+
-+ if ( !_ecore_fb_tslib_tsdev )
-+ {
-+ printf( "ECORE_FB: Can't ts_open (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+
-+ if ( ts_config( _ecore_fb_tslib_tsdev ) )
-+ {
-+ printf( "ECORE_FB: Can't ts_config (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+ _ecore_fb_ts_fd = ts_fd( _ecore_fb_tslib_tsdev );
-+ if ( _ecore_fb_ts_fd < 0 )
-+ {
-+ printf( "ECORE_FB: Can't open touchscreen (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+ }
-+#else
- _ecore_fb_ts_fd = open("/dev/touchscreen/0", O_RDONLY);
-+#endif
- if (_ecore_fb_ts_fd >= 0)
- {
- prev_flags = fcntl(_ecore_fb_ts_fd, F_GETFL);
-@@ -790,7 +831,21 @@
- char *ptr;
- double t;
- int did_triple = 0;
--
-+
-+#ifdef HAVE_TSLIB
-+ if ( _ecore_fb_ts_apply_cal )
-+ num = ts_read_raw( _ecore_fb_tslib_tsdev, &_ecore_fb_tslib_event, 1 );
-+ else
-+ num = ts_read( _ecore_fb_tslib_tsdev, &_ecore_fb_tslib_event, 1 );
-+ if ( num != 1 )
-+ {
-+ return 1; /* no more samples at this time */
-+ }
-+ x = _ecore_fb_tslib_event.x;
-+ y = _ecore_fb_tslib_event.y;
-+ pressure = _ecore_fb_tslib_event.pressure;
-+ v = 1; /* loop, there might be more samples */
-+#else
- ptr = (char *)&(_ecore_fb_ts_event);
- ptr += _ecore_fb_ts_event_byte_count;
- num = sizeof(Ecore_Fb_Ts_Event) - _ecore_fb_ts_event_byte_count;
-@@ -811,6 +866,7 @@
- y = _ecore_fb_ts_event.y;
- }
- pressure = _ecore_fb_ts_event.pressure;
-+#endif
- /* add event to queue */
- /* always add a move event */
- if ((pressure) || (prev_pressure))
diff --git a/recipes/efl1/ecore/fix-directfb-include.patch b/recipes/efl1/ecore/fix-directfb-include.patch
deleted file mode 100644
index b1c06f7f43..0000000000
--- a/recipes/efl1/ecore/fix-directfb-include.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ecore-0.9.9.038/src/lib/ecore_directfb/Ecore_DirectFB.h
-===================================================================
---- ecore-0.9.9.038.orig/src/lib/ecore_directfb/Ecore_DirectFB.h
-+++ ecore-0.9.9.038/src/lib/ecore_directfb/Ecore_DirectFB.h
-@@ -23,7 +23,7 @@
- #endif
-
- #include <Ecore_Data.h>
--#include <directfb.h>
-+#include <directfb/directfb.h>
-
-
- #ifdef __cplusplus
diff --git a/recipes/efl1/imlib2/remove-local-includes-20080421.patch b/recipes/efl1/imlib2/remove-local-includes-20080421.patch
deleted file mode 100644
index d28ba9ebf0..0000000000
--- a/recipes/efl1/imlib2/remove-local-includes-20080421.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: imlib2/configure.in
-===================================================================
---- imlib2.orig/configure.in 2008-04-21 14:28:58.000000000 +0800
-+++ imlib2/configure.in 2008-04-21 14:30:07.000000000 +0800
-@@ -191,9 +191,7 @@
-
- if test "x$have_x" = "xyes"; then
- AC_PATH_XTRA
-- x_dir=${x_dir:-/usr/X11R6}
-- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
-- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
-+ x_libs="-lX11 -lXext"
- AC_DEFINE(BUILD_X11, 1, [enabling X11 support])
- else
- x_cflags=""