aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-11 10:25:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-19 20:34:51 +0100
commitd6f29aecf1c0a857dcbbceb770b38da5040e980b (patch)
tree4f83bede701bb656b8e7a561860e7e486d77f076 /recipes/efl1
parente725b0a4fca9dab1ad19221c7c056aefb3d63d0a (diff)
downloadopenembedded-d6f29aecf1c0a857dcbbceb770b38da5040e980b.tar.gz
ecore: convert BBCLASSEXTEND
* different EXTRA_OECONF weren't used for -native as the diff seems rather unintentional when OECONF was updated only in non-native version, feel free to add it if really needed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/ecore-native_svn.bb32
-rw-r--r--recipes/efl1/ecore.inc7
-rw-r--r--recipes/efl1/ecore_svn.bb10
3 files changed, 15 insertions, 34 deletions
diff --git a/recipes/efl1/ecore-native_svn.bb b/recipes/efl1/ecore-native_svn.bb
deleted file mode 100644
index 7963574c7b..0000000000
--- a/recipes/efl1/ecore-native_svn.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-require ecore.inc
-inherit native
-DEPENDS = "eet-native evas-native"
-PR = "r4"
-
-EXTRA_OECONF = "\
- --enable-ecore-txt \
- --enable-ecore-config \
- --disable-ecore-x-xcb \
- --disable-ecore-x \
- --enable-ecore-job \
- --disable-ecore-directfb \
- --disable-ecore-sdl \
- --enable-ecore-fb \
- --enable-ecore-evas \
- --enable-ecore-evas-fb \
- --disable-ecore-evas-x11-gl \
- --disable-ecore-evas-xrender \
- --disable-ecore-evas-dfb \
- --disable-ecore-evas-sdl \
- --disable-openssl \
- --enable-abstract-sockets \
- --enable-ecore-con \
- --enable-ecore-ipc \
- --enable-ecore-file \
- --enable-inotify \
- --disable-poll \
- --disable-curl \
- --disable-ecore-desktop \
- --disable-ecore-imf \
- --disable-ecore-imf_evas \
-"
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index 69d3f7607c..183f25203a 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -1,14 +1,17 @@
DESCRIPTION = "Ecore is the Enlightenment application framework library"
LICENSE = "MIT BSD"
-DEPENDS = "gettext-native virtual/libiconv curl eet evas tslib glib-2.0 \
+DEPENDS = "gettext-native virtual/libiconv tslib curl eet evas glib-2.0 \
libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxprintutil"
+DEPENDS_virtclass-native = "eet-native evas-native"
# optional
# DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
PV = "0.9.9.060+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
inherit efl
+BBCLASSEXTEND = "native"
+
SRC_URI += "file://fix-ecore-fb-initialization.patch;patch=1"
do_configure_prepend() {
diff --git a/recipes/efl1/ecore_svn.bb b/recipes/efl1/ecore_svn.bb
index e3fdf588bc..5262c0c91f 100644
--- a/recipes/efl1/ecore_svn.bb
+++ b/recipes/efl1/ecore_svn.bb
@@ -35,3 +35,13 @@ EXTRA_OECONF = "\
--disable-openssl \
--disable-poll \
"
+
+# List of options which were different in ecore-native,
+# I know it's SCM, but with missing -native.bb is much easier to check here
+#EXTRA_OECONF_virtclass-native = "\
+# --disable-ecore-x \
+# --enable-ecore-evas-fb \
+# --disable-ecore-evas-x11-gl \
+# --disable-curl \
+# --disable-ecore-imf \
+# --disable-ecore-imf_evas \