summaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-21 17:32:53 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-21 17:32:53 +0200
commitd79b58e6967793ac7c88f0f63d00f06b334f0f70 (patch)
treebb9b9b39f79fd4dc7083e0cb879dab17488049fc /recipes/efl1
parentd8f34cd4400e9f0e5b5b221be531690a00dd127e (diff)
downloadopenembedded-d79b58e6967793ac7c88f0f63d00f06b334f0f70.tar.gz
etk: hack around gettext breakage
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/etk_svn.bb10
-rwxr-xr-xrecipes/efl1/files/mkinstalldirs161
2 files changed, 170 insertions, 1 deletions
diff --git a/recipes/efl1/etk_svn.bb b/recipes/efl1/etk_svn.bb
index 5c47c406d2..31004a357f 100644
--- a/recipes/efl1/etk_svn.bb
+++ b/recipes/efl1/etk_svn.bb
@@ -2,10 +2,12 @@ DESCRIPTION = "Etk is an advanced widget toolkit based on the Enlightenment Foun
DEPENDS = "evas ecore edje"
LICENSE = "MIT"
PV = "0.1.0.042+svnr${SRCREV}"
-PR = "r4"
+PR = "r5"
inherit efl
+SRC_URI += "file://mkinstalldirs"
+
RRECOMMENDS_${PN} = "\
etk-engines-software-x11 \
etk-engines-evas \
@@ -14,6 +16,12 @@ RRECOMMENDS_${PN} = "\
etk-engines-software-x11-16 \
"
+do_compile_prepend() {
+ touch ${S}/po/etk.pot
+ cp ${WORKDIR}/mkinstalldirs ${S}
+ sed -i -e 's:@MKINSTALLDIRS@:${S}/mkinstalldirs:g' ${S}/po/Makefile
+}
+
PACKAGES += "etk-engines-software-x11"
FILES_${PN}-engines-software-x11 = "${libdir}/etk/engines/ecore_evas_software_x11.so"
diff --git a/recipes/efl1/files/mkinstalldirs b/recipes/efl1/files/mkinstalldirs
new file mode 100755
index 0000000000..ef7e16fdaf
--- /dev/null
+++ b/recipes/efl1/files/mkinstalldirs
@@ -0,0 +1,161 @@
+#! /bin/sh
+# mkinstalldirs --- make directory hierarchy
+
+scriptversion=2006-05-11.19
+
+# Original author: Noah Friedman <friedman@prep.ai.mit.edu>
+# Created: 1993-05-16
+# Public domain.
+#
+# This file is maintained in Automake, please report
+# bugs to <bug-automake@gnu.org> or send patches to
+# <automake-patches@gnu.org>.
+
+nl='
+'
+IFS=" "" $nl"
+errstatus=0
+dirmode=
+
+usage="\
+Usage: mkinstalldirs [-h] [--help] [--version] [-m MODE] DIR ...
+
+Create each directory DIR (with mode MODE, if specified), including all
+leading file name components.
+
+Report bugs to <bug-automake@gnu.org>."
+
+# process command line arguments
+while test $# -gt 0 ; do
+ case $1 in
+ -h | --help | --h*) # -h for help
+ echo "$usage"
+ exit $?
+ ;;
+ -m) # -m PERM arg
+ shift
+ test $# -eq 0 && { echo "$usage" 1>&2; exit 1; }
+ dirmode=$1
+ shift
+ ;;
+ --version)
+ echo "$0 $scriptversion"
+ exit $?
+ ;;
+ --) # stop option processing
+ shift
+ break
+ ;;
+ -*) # unknown option
+ echo "$usage" 1>&2
+ exit 1
+ ;;
+ *) # first non-opt arg
+ break
+ ;;
+ esac
+done
+
+for file
+do
+ if test -d "$file"; then
+ shift
+ else
+ break
+ fi
+done
+
+case $# in
+ 0) exit 0 ;;
+esac
+
+# Solaris 8's mkdir -p isn't thread-safe. If you mkdir -p a/b and
+# mkdir -p a/c at the same time, both will detect that a is missing,
+# one will create a, then the other will try to create a and die with
+# a "File exists" error. This is a problem when calling mkinstalldirs
+# from a parallel make. We use --version in the probe to restrict
+# ourselves to GNU mkdir, which is thread-safe.
+case $dirmode in
+ '')
+ if mkdir -p --version . >/dev/null 2>&1 && test ! -d ./--version; then
+ echo "mkdir -p -- $*"
+ exec mkdir -p -- "$@"
+ else
+ # On NextStep and OpenStep, the `mkdir' command does not
+ # recognize any option. It will interpret all options as
+ # directories to create, and then abort because `.' already
+ # exists.
+ test -d ./-p && rmdir ./-p
+ test -d ./--version && rmdir ./--version
+ fi
+ ;;
+ *)
+ if mkdir -m "$dirmode" -p --version . >/dev/null 2>&1 &&
+ test ! -d ./--version; then
+ echo "mkdir -m $dirmode -p -- $*"
+ exec mkdir -m "$dirmode" -p -- "$@"
+ else
+ # Clean up after NextStep and OpenStep mkdir.
+ for d in ./-m ./-p ./--version "./$dirmode";
+ do
+ test -d $d && rmdir $d
+ done
+ fi
+ ;;
+esac
+
+for file
+do
+ case $file in
+ /*) pathcomp=/ ;;
+ *) pathcomp= ;;
+ esac
+ oIFS=$IFS
+ IFS=/
+ set fnord $file
+ shift
+ IFS=$oIFS
+
+ for d
+ do
+ test "x$d" = x && continue
+
+ pathcomp=$pathcomp$d
+ case $pathcomp in
+ -*) pathcomp=./$pathcomp ;;
+ esac
+
+ if test ! -d "$pathcomp"; then
+ echo "mkdir $pathcomp"
+
+ mkdir "$pathcomp" || lasterr=$?
+
+ if test ! -d "$pathcomp"; then
+ errstatus=$lasterr
+ else
+ if test ! -z "$dirmode"; then
+ echo "chmod $dirmode $pathcomp"
+ lasterr=
+ chmod "$dirmode" "$pathcomp" || lasterr=$?
+
+ if test ! -z "$lasterr"; then
+ errstatus=$lasterr
+ fi
+ fi
+ fi
+ fi
+
+ pathcomp=$pathcomp/
+ done
+done
+
+exit $errstatus
+
+# Local Variables:
+# mode: shell-script
+# sh-indentation: 2
+# eval: (add-hook 'write-file-hooks 'time-stamp)
+# time-stamp-start: "scriptversion="
+# time-stamp-format: "%:y-%02m-%02d.%02H"
+# time-stamp-end: "$"
+# End: