summaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-12-02 01:44:58 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-12-02 01:44:58 +0100
commiteb99a8719f48afcf5dff5d8f853382b9c42b6d48 (patch)
treeffd530d00b36e9e74972c458c7ae489756412784 /recipes/efl1
parent237cbb465699c4503598ef606f6d3b7e5ab45e7f (diff)
downloadopenembedded-eb99a8719f48afcf5dff5d8f853382b9c42b6d48.tar.gz
libeweather: new recipe; EFL-based weather report library
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/libeweather_svn.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/efl1/libeweather_svn.bb b/recipes/efl1/libeweather_svn.bb
new file mode 100644
index 0000000000..6668f08278
--- /dev/null
+++ b/recipes/efl1/libeweather_svn.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "EFL-based weather widget library"
+LICENSE = "LGPL"
+DEPENDS = "ecore edje"
+PV = "0.0.0+svnr${SRCPV}"
+PR = "r0"
+
+inherit efl
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=eweather;proto=http"
+S = "${WORKDIR}/eweather"
+
+RSUGGESTS_${PN} = "elementary-tests"
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ eweather.pc
+}
+
+PACKAGES += "${PN}-plugins"
+
+FILES_${PN}-themes = "\
+ ${datadir} \
+"
+
+FILES_${PN}-plugins = "\
+ ${libdir}/eweather/plugins/*.so \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/eweather/plugins/.debug \
+"
+
+FILES_${PN}-dev += "\
+ ${libdir}/eweather/plugins/*.a \
+ ${libdir}/eweather/plugins/*.la \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-themes \
+ ${PN}-plugins \
+"