aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eggdbus
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-22 00:36:54 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-22 00:38:59 +0000
commita4cebe9f1d505fbcc040ba67a927e543125f5854 (patch)
tree479788107b38323ae53a940550842e572a2ee771 /recipes/eggdbus
parent5cc04010e70378484efe549b30b411f840e825f5 (diff)
downloadopenembedded-a4cebe9f1d505fbcc040ba67a927e543125f5854.tar.gz
eggdbus_0.6.bb : add this new recipe which is gobject bindings for dbus
This is required by the newer policykit packages which I am working on pulling into OE.
Diffstat (limited to 'recipes/eggdbus')
-rw-r--r--recipes/eggdbus/eggdbus_0.6.bb22
-rw-r--r--recipes/eggdbus/files/gtk-doc.patch32
-rw-r--r--recipes/eggdbus/files/marshal.patch26
3 files changed, 80 insertions, 0 deletions
diff --git a/recipes/eggdbus/eggdbus_0.6.bb b/recipes/eggdbus/eggdbus_0.6.bb
new file mode 100644
index 0000000000..1d8717929b
--- /dev/null
+++ b/recipes/eggdbus/eggdbus_0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "gobject dbus binding"
+HOMEPAGE = "http://cgit.freedesktop.org/~david/eggdbus"
+LICENSE = "GPLv2"
+
+DEPENDS = "dbus glib-2.0"
+
+BASE_SRC_URI = "http://cgit.freedesktop.org/~david/${BPN}/snapshot/${BPN}-${PV}.tar.bz2 \
+ file://gtk-doc.patch;patch=1 \
+ "
+
+SRC_URI = "${BASE_SRC_URI} \
+ file://marshal.patch;patch=1 \
+ "
+
+SRC_URI_virtclass-native = "${BASE_SRC_URI}"
+
+inherit autotools
+
+EXTRA_OECONF = " --disable-man-pages --disable-gtk-doc-html "
+
+BBCLASSEXTEND = "native"
+
diff --git a/recipes/eggdbus/files/gtk-doc.patch b/recipes/eggdbus/files/gtk-doc.patch
new file mode 100644
index 0000000000..0999a85153
--- /dev/null
+++ b/recipes/eggdbus/files/gtk-doc.patch
@@ -0,0 +1,32 @@
+Index: eggdbus-0.6/docs/eggdbus/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/docs/eggdbus/Makefile.am
++++ eggdbus-0.6/docs/eggdbus/Makefile.am
+@@ -87,11 +87,7 @@ HTML_IMAGES = \
+ # Extra options to supply to gtkdoc-fixref
+ FIXXREF_OPTIONS=
+
+-if ENABLE_GTK_DOC
+-include $(top_srcdir)/gtk-doc.make
+-else
+ CLEANFILES =
+-endif
+
+ CLEANFILES += *~ \
+ eggdbus-scan.* \
+Index: eggdbus-0.6/docs/tests/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/docs/tests/Makefile.am
++++ eggdbus-0.6/docs/tests/Makefile.am
+@@ -65,11 +65,7 @@ HTML_IMAGES = \
+ # Extra options to supply to gtkdoc-fixref
+ FIXXREF_OPTIONS=
+
+-if ENABLE_GTK_DOC
+-include $(top_srcdir)/gtk-doc.make
+-else
+ CLEANFILES =
+-endif
+
+ CLEANFILES += *~ \
+ tests-scan.* \
diff --git a/recipes/eggdbus/files/marshal.patch b/recipes/eggdbus/files/marshal.patch
new file mode 100644
index 0000000000..2b2cb4985b
--- /dev/null
+++ b/recipes/eggdbus/files/marshal.patch
@@ -0,0 +1,26 @@
+Index: eggdbus-0.6/src/eggdbus/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/src/eggdbus/Makefile.am
++++ eggdbus-0.6/src/eggdbus/Makefile.am
+@@ -130,7 +130,7 @@ BUILT_SOURCES = \
+ $(NULL)
+
+ eggdbus-built-sources.stamp : eggdbus-binding-tool Makefile.am org.freedesktop.DBus.xml org.freedesktop.DBus.Peer.xml org.freedesktop.DBus.Properties.xml org.freedesktop.DBus.Introspectable.xml eggdbus-glib-genmarshal
+- EGG_DBUS_GENMARSHAL=$(top_builddir)/src/eggdbus/eggdbus-glib-genmarshal $(top_builddir)/src/eggdbus/eggdbus-binding-tool \
++ EGG_DBUS_GENMARSHAL=eggdbus-glib-genmarshal eggdbus-binding-tool \
+ --namespace EggDBus \
+ --dbus-namespace org.freedesktop.DBus \
+ --interfaces-only \
+Index: eggdbus-0.6/src/tests/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/src/tests/Makefile.am
++++ eggdbus-0.6/src/tests/Makefile.am
+@@ -25,7 +25,7 @@ BUILT_SOURCES = \
+ $(NULL)
+
+ test-built-sources.stamp : Makefile.am $(top_builddir)/src/eggdbus/eggdbus-binding-tool com.example.Frob.xml com.example.Tweak.xml com.example.Twiddle.xml
+- EGG_DBUS_GENMARSHAL=$(top_builddir)/src/eggdbus/eggdbus-glib-genmarshal $(top_builddir)/src/eggdbus/eggdbus-binding-tool \
++ EGG_DBUS_GENMARSHAL=eggdbus-glib-genmarshal eggdbus-binding-tool \
+ --namespace "Test" \
+ --dbus-namespace "com.example" \
+ --include-header testtypes.h \