aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/eibd
diff options
context:
space:
mode:
authorDirk Opfer <dirk@do13.de>2009-04-22 10:24:54 +0200
committerDirk Opfer <dirk@do13.de>2009-04-22 10:24:54 +0200
commitb2c58f438d407186f3f6c4eb86e6fc070e71b42e (patch)
tree988d4dc9e0de58062689f714a2e541d19e2c27cc /recipes/eibd
parent6a64f6e927dd42d4d91cb6679cca04ce1ab65f47 (diff)
downloadopenembedded-b2c58f438d407186f3f6c4eb86e6fc070e71b42e.tar.gz
eibd: new recipe, version 0.0.4
Eibd provides an interface to the EIB / KNX bus
Diffstat (limited to 'recipes/eibd')
-rw-r--r--recipes/eibd/eibd_0.0.4.bb62
-rwxr-xr-xrecipes/eibd/files/eibd59
2 files changed, 121 insertions, 0 deletions
diff --git a/recipes/eibd/eibd_0.0.4.bb b/recipes/eibd/eibd_0.0.4.bb
new file mode 100644
index 0000000000..23e2c0832c
--- /dev/null
+++ b/recipes/eibd/eibd_0.0.4.bb
@@ -0,0 +1,62 @@
+DESCRIPTION = "Eibd provides an interface to the EIB / KNX bus"
+HOMEPAGE = "http://www.auto.tuwien.ac.at/~mkoegler/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = " pthsem libxml2"
+DEPENDS_append_linux-uclibc = " argp-standalone "
+DEPENDS_append_linux-uclibcgnueabi = " argp-standalone "
+
+SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/bcusdk_${PV}.tar.gz \
+ file://eibd "
+
+S = "${WORKDIR}/bcusdk-${PV}"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = " --with-pth=yes --without-pth-test \
+ --enable-onlyeibd \
+ --enable-pei16 \
+ --enable-ft12 \
+ --enable-tpuart \
+ --enable-pei16s \
+ --enable-tpuarts \
+ --enable-usb \
+ --enable-eibnetip \
+ --enable-eibnetiptunnel \
+ --enable-eibnetipserver \
+ "
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/default/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/eibd ${D}${sysconfdir}/init.d/eibd
+}
+
+PACKAGES =+ "eibd-server eibd-clients libeibclient-dev"
+
+FILES_eibd-server = "${bindir}/eibnetsearch ${bindir}/findknxusb \
+ ${bindir}/eibd ${bindir}/bcuaddrtab \
+ ${bindir}/eibnetdescribe ${bindir}/bcuread \
+ ${sysconfdir}/init.d/eibd "
+FILES_eibd-clients = "${bindir}/*"
+FILES_libeibclient-dev = "\
+ ${includedir} \
+ ${libdir}/lib*.so \
+ ${libdir}/*.la \
+ ${libdir}/*.a \
+ ${libdir}/*.o \
+ ${libdir}/pkgconfig \
+ /lib/*.a \
+ /lib/*.o \
+ ${datadir}/aclocal"
+
+DESCRIPTION_eibd-clients = "Simple example programs to perform management tasks on a EIB system."
+DESCRIPTION_libeibclient-dev = "A client library written in C to access the EIB bus over eibd."
+DESCRIPTION_eibd-server = "eibd is a daemon which supports connection to an EIB (KNX) network over various \
+interfaces. It provides its services over TCP/IP or Unix domain sockets. \
+It can also act as an EIBnet/IP server."
+
+INITSCRIPT_PACKAGES = "eibd-server"
+INITSCRIPT_NAME = "eibd"
+INITSCRIPT_PARAMS = "defaults 20"
diff --git a/recipes/eibd/files/eibd b/recipes/eibd/files/eibd
new file mode 100755
index 0000000000..953fbb8f80
--- /dev/null
+++ b/recipes/eibd/files/eibd
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/bin
+
+DAEMON="eibd"
+
+test -f /usr/bin/${DAEMON} || exit 0
+
+if test -f /etc/default/${DAEMON} ; then
+. /etc/default/${DAEMON}
+else
+:
+fi
+
+if [ "$START_EIBD" != "yes" ]
+then
+ exit 0
+fi
+
+startdaemon(){
+ echo -n "Starting ${DAEMON}: "
+ start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+stopdaemon(){
+ echo -n "Stopping ${DAEMON}: "
+ start-stop-daemon --stop -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+
+
+case "$1" in
+ start)
+ startdaemon
+ ;;
+ stop)
+ stopdaemon
+ ;;
+ force-reload)
+ stopdaemon
+ startdaemon
+ ;;
+ restart)
+ stopdaemon
+ startdaemon
+ ;;
+ reload)
+ stopdaemon
+ startdaemon
+ ;;
+ *)
+ echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
+ exit 1
+ ;;
+esac
+
+exit 0