aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga/opal_3.6.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-21 23:26:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-21 23:26:25 +0200
commit2a20dd7eef485b7e024c20d701dec46e63638b38 (patch)
treefbf88c30d9aca615b5166b90f76338dae0e14ff3 /recipes/ekiga/opal_3.6.2.bb
parent4c275b5c0350ed1dbd94bfcdd9ce8786ad11b8a1 (diff)
downloadopenembedded-2a20dd7eef485b7e024c20d701dec46e63638b38.tar.gz
ekiga: update ekiga bits to 3.2.4
Diffstat (limited to 'recipes/ekiga/opal_3.6.2.bb')
-rw-r--r--recipes/ekiga/opal_3.6.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ekiga/opal_3.6.2.bb b/recipes/ekiga/opal_3.6.2.bb
new file mode 100644
index 0000000000..502c344b13
--- /dev/null
+++ b/recipes/ekiga/opal_3.6.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+