aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga/opal_3.6.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-21 11:16:48 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-21 11:16:48 +0200
commitadb397605ea57d5b8182037c3f75b78f4ab07a5f (patch)
treeafde243191f149ad8425e5afdc49de22b8200ddd /recipes/ekiga/opal_3.6.4.bb
parentacb6551a2ab3352006f3822c9f374afba732146d (diff)
downloadopenembedded-adb397605ea57d5b8182037c3f75b78f4ab07a5f.tar.gz
opal: update to 3.6.4
Diffstat (limited to 'recipes/ekiga/opal_3.6.4.bb')
-rw-r--r--recipes/ekiga/opal_3.6.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ekiga/opal_3.6.4.bb b/recipes/ekiga/opal_3.6.4.bb
new file mode 100644
index 0000000000..502c344b13
--- /dev/null
+++ b/recipes/ekiga/opal_3.6.4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+