aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-07-15 09:40:13 +0200
committerKoen Kooi <koen@openembedded.org>2010-07-15 09:40:13 +0200
commit0c26dace022122598c70a8f24c9bf26b2507b0c5 (patch)
treee6095b865ff1895d8d67ecf03f9781150606e69b /recipes/ekiga
parentfc29167bbe48a053ad8d2295dbdb65182aea13d6 (diff)
downloadopenembedded-0c26dace022122598c70a8f24c9bf26b2507b0c5.tar.gz
opal: add 3.8.2
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/opal_3.8.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/ekiga/opal_3.8.2.bb b/recipes/ekiga/opal_3.8.2.bb
new file mode 100644
index 0000000000..46ebaecb5f
--- /dev/null
+++ b/recipes/ekiga/opal_3.8.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+SRC_URI = "http://garr.dl.sourceforge.net/project/opalvoip/v3.8%20Sirius/Stable%202/opal-${PV}.tar.bz2;name=opal \
+ "
+SRC_URI[opal.md5sum] = "dff4204187f4a43ea8c2be376ea6155b"
+SRC_URI[opal.sha256sum] = "a699f4c3710a2ddb5ae9a6cba0e303bbd29a94ed011f642b7763729a61598c7c"
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+TARGET_CC_ARCH += "-D__STDC_CONSTANT_MACROS"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"