aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-02 09:13:23 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-02 09:58:38 +0100
commitac799de1906b8e7aa1ab65698a27a5ad284621e1 (patch)
treec474c83cf29fcf82a4e57c2fc8f6a7572b7033bc /recipes/ekiga
parent5ba1e9d435c7235c1328d788d31978d58a611aee (diff)
downloadopenembedded-ac799de1906b8e7aa1ab65698a27a5ad284621e1.tar.gz
opal: add 3.8.0
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/opal_3.8.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/ekiga/opal_3.8.0.bb b/recipes/ekiga/opal_3.8.0.bb
new file mode 100644
index 0000000000..371d6aedad
--- /dev/null
+++ b/recipes/ekiga/opal_3.8.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2;name=opal \
+ "
+SRC_URI[opal.md5sum] = "6fd24f0250974a234c5a3d239fc95d21"
+SRC_URI[opal.sha256sum] = "80af07c69c7ec0402c1360ab03818ffe7629d1ef80e7dbb8cf66d40e0c95c365"
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"