aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/elfutils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/elfutils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/elfutils')
-rw-r--r--recipes/elfutils/elfutils-0.127/warnings.patch149
-rw-r--r--recipes/elfutils/elfutils-0.131/warnings.patch149
-rw-r--r--recipes/elfutils/elfutils-0.89/warnings.patch98
-rw-r--r--recipes/elfutils/elfutils_0.127.bb15
-rw-r--r--recipes/elfutils/elfutils_0.131.bb15
-rw-r--r--recipes/elfutils/elfutils_0.89.bb43
6 files changed, 469 insertions, 0 deletions
diff --git a/recipes/elfutils/elfutils-0.127/warnings.patch b/recipes/elfutils/elfutils-0.127/warnings.patch
new file mode 100644
index 0000000000..454706de4b
--- /dev/null
+++ b/recipes/elfutils/elfutils-0.127/warnings.patch
@@ -0,0 +1,149 @@
+Index: elfutils-0.127/configure.ac
+===================================================================
+--- elfutils-0.127.orig/configure.ac 2007-04-19 07:55:07.000000000 +0100
++++ elfutils-0.127/configure.ac 2008-03-26 10:45:54.000000000 +0000
+@@ -55,6 +55,10 @@
+ dnl Add all the languages for which translations are available.
+ ALL_LINGUAS=
+
++if test X"$CFLAGS" = X; then
++ CFLAGS="-Wall -Werror -g -O2"
++fi
++
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+Index: elfutils-0.127/lib/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/lib/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/lib/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra $($(*F)_CFLAGS)
++AM_CFLAGS += -fpic -Wshadow -Wunused $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir)/../libelf -I..
+
+ noinst_LIBRARIES = libeu.a
+Index: elfutils-0.127/libasm/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libasm/Makefile.am 2006-08-29 20:31:57.000000000 +0100
++++ elfutils-0.127/libasm/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
++AM_CFLAGS += -std=gnu99 -Wshadow -Wunused -Wformat=2
+ INCLUDES = -I. -I$(srcdir) -I.. \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
+ -I$(top_srcdir)/lib
+Index: elfutils-0.127/libcpu/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libcpu/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/libcpu/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -25,7 +25,7 @@
+ ## <http://www.openinventionnetwork.com>.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Wshadow -Werror -Wextra -Wformat=2 -Wunused
++AM_CFLAGS = -Wshadow -Wformat=2 -Wunused
+ INCLUDES = -I$(srcdir)
+
+ noinst_LIBRARIES = libcpu_i386.a
+Index: elfutils-0.127/libdw/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdw/Makefile.am 2007-04-05 11:26:50.000000000 +0100
++++ elfutils-0.127/libdw/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
+ VERSION = 1
+
+Index: elfutils-0.127/libebl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libebl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libebl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libelf/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libelf/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libelf/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99 \
+ $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
+ GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
+Index: elfutils-0.127/tests/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/tests/Makefile.am 2007-04-18 21:44:32.000000000 +0100
++++ elfutils-0.127/tests/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -26,11 +26,11 @@
+ ##
+ DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
+ if MUDFLAP
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
++AM_CFLAGS = -std=gnu99 -fmudflap\
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILD_RPATH = \$$ORIGIN/../backends
+ else
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
++AM_CFLAGS = -std=gnu99 \
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
+ endif
+Index: elfutils-0.127/backends/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/backends/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/backends/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libdwfl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdwfl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libdwfl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -32,7 +32,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+ -I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
+ VERSION = 1
+Index: elfutils-0.127/src/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/src/Makefile.am 2008-03-26 10:48:00.000000000 +0000
++++ elfutils-0.127/src/Makefile.am 2008-03-26 10:48:21.000000000 +0000
+@@ -32,7 +32,6 @@
+ AM_CFLAGS =
+ endif
+ AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
+- $(if $($(*F)_no_Werror),,-Werror) \
+ $(if $($(*F)_no_Wunused),,-Wunused -Wextra) \
+ $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
+
diff --git a/recipes/elfutils/elfutils-0.131/warnings.patch b/recipes/elfutils/elfutils-0.131/warnings.patch
new file mode 100644
index 0000000000..454706de4b
--- /dev/null
+++ b/recipes/elfutils/elfutils-0.131/warnings.patch
@@ -0,0 +1,149 @@
+Index: elfutils-0.127/configure.ac
+===================================================================
+--- elfutils-0.127.orig/configure.ac 2007-04-19 07:55:07.000000000 +0100
++++ elfutils-0.127/configure.ac 2008-03-26 10:45:54.000000000 +0000
+@@ -55,6 +55,10 @@
+ dnl Add all the languages for which translations are available.
+ ALL_LINGUAS=
+
++if test X"$CFLAGS" = X; then
++ CFLAGS="-Wall -Werror -g -O2"
++fi
++
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+Index: elfutils-0.127/lib/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/lib/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/lib/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra $($(*F)_CFLAGS)
++AM_CFLAGS += -fpic -Wshadow -Wunused $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir)/../libelf -I..
+
+ noinst_LIBRARIES = libeu.a
+Index: elfutils-0.127/libasm/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libasm/Makefile.am 2006-08-29 20:31:57.000000000 +0100
++++ elfutils-0.127/libasm/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
++AM_CFLAGS += -std=gnu99 -Wshadow -Wunused -Wformat=2
+ INCLUDES = -I. -I$(srcdir) -I.. \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
+ -I$(top_srcdir)/lib
+Index: elfutils-0.127/libcpu/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libcpu/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/libcpu/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -25,7 +25,7 @@
+ ## <http://www.openinventionnetwork.com>.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Wshadow -Werror -Wextra -Wformat=2 -Wunused
++AM_CFLAGS = -Wshadow -Wformat=2 -Wunused
+ INCLUDES = -I$(srcdir)
+
+ noinst_LIBRARIES = libcpu_i386.a
+Index: elfutils-0.127/libdw/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdw/Makefile.am 2007-04-05 11:26:50.000000000 +0100
++++ elfutils-0.127/libdw/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
+ VERSION = 1
+
+Index: elfutils-0.127/libebl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libebl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libebl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libelf/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libelf/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libelf/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99 \
+ $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
+ GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
+Index: elfutils-0.127/tests/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/tests/Makefile.am 2007-04-18 21:44:32.000000000 +0100
++++ elfutils-0.127/tests/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -26,11 +26,11 @@
+ ##
+ DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
+ if MUDFLAP
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
++AM_CFLAGS = -std=gnu99 -fmudflap\
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILD_RPATH = \$$ORIGIN/../backends
+ else
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
++AM_CFLAGS = -std=gnu99 \
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
+ endif
+Index: elfutils-0.127/backends/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/backends/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/backends/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libdwfl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdwfl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libdwfl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -32,7 +32,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+ -I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
+ VERSION = 1
+Index: elfutils-0.127/src/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/src/Makefile.am 2008-03-26 10:48:00.000000000 +0000
++++ elfutils-0.127/src/Makefile.am 2008-03-26 10:48:21.000000000 +0000
+@@ -32,7 +32,6 @@
+ AM_CFLAGS =
+ endif
+ AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
+- $(if $($(*F)_no_Werror),,-Werror) \
+ $(if $($(*F)_no_Wunused),,-Wunused -Wextra) \
+ $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
+
diff --git a/recipes/elfutils/elfutils-0.89/warnings.patch b/recipes/elfutils/elfutils-0.89/warnings.patch
new file mode 100644
index 0000000000..2a1ea09a61
--- /dev/null
+++ b/recipes/elfutils/elfutils-0.89/warnings.patch
@@ -0,0 +1,98 @@
+--- elfutils-0.89/configure.ac~warnings.patch 2003-09-26 02:04:04.000000000 -0400
++++ elfutils-0.89/configure.ac 2004-05-01 00:16:33.000000000 -0400
+@@ -28,6 +28,10 @@
+
+ ALL_LINGUAS=
+
++if test X"$CFLAGS" = X; then
++ CFLAGS="-Wall -Werror -g -O2"
++fi
++
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_GCC_TRADITIONAL
+--- elfutils-0.89/./lib/Makefile.am~warnings.patch 2003-09-22 18:57:58.000000000 -0400
++++ elfutils-0.89/./lib/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,7 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Werror -fpic
++AM_CFLAGS = -fpic
+ INCLUDES = -I$(srcdir)/../libelf -I..
+
+ noinst_LIBRARIES = libeu.a
+--- elfutils-0.89/./libelf/Makefile.am~warnings.patch 2003-08-12 02:45:24.000000000 -0400
++++ elfutils-0.89/./libelf/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,6 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Werror
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
+ GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
+ VERSION = 1
+--- elfutils-0.89/./libebl/Makefile.am~warnings.patch 2003-09-22 18:53:17.000000000 -0400
++++ elfutils-0.89/./libebl/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,7 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -Wall
+-AM_CFLAGS = -Wall -Werror -DOBJDIR=\"$(shell pwd)\" -fpic
++AM_CFLAGS = -DOBJDIR=\"$(shell pwd)\" -fpic
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/lib -I..
+ VERSION = 1
+ PACKAGE_VERSION = @PACKAGE_VERSION@
+--- elfutils-0.89/./libdwarf/Makefile.am~warnings.patch 2003-08-12 02:46:05.000000000 -0400
++++ elfutils-0.89/./libdwarf/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,6 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -DDWARF_DEBUG
+-AM_CFLAGS = -Wall -Werror
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
+ VERSION = 1
+
+--- elfutils-0.89/./libdw/Makefile.am~warnings.patch 2003-08-12 02:46:18.000000000 -0400
++++ elfutils-0.89/./libdw/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -17,7 +17,6 @@
+ ## Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Werror -Wshadow
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
+ VERSION = 1
+
+--- elfutils-0.89/./libasm/Makefile.am~warnings.patch 2003-08-13 05:21:25.000000000 -0400
++++ elfutils-0.89/./libasm/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,6 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Werror
+ INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
+ -I$(top_srcdir)/lib
+ GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
+--- elfutils-0.89/./src/Makefile.am~warnings.patch 2003-09-22 18:57:09.000000000 -0400
++++ elfutils-0.89/./src/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,8 +14,8 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -Wall -Wshadow $(YYDEBUG) \
+- $(if $($(*F)_no_Werror),,-Werror) $(native_ld_cflags)
+-AM_CFLAGS = -Wall -DSRCDIR=\"$(shell cd $(srcdir);pwd)\" -DOBJDIR=\"$(shell pwd)\"
++ $(if $(filter -Werror,$(CFLAGS)),$(if $($(*F)_no_Werror),,-Werror)) $(native_ld_cflags)
++AM_CFLAGS = -DSRCDIR=\"$(shell cd $(srcdir);pwd)\" -DOBJDIR=\"$(shell pwd)\"
+ INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl -I$(srcdir)/../lib -I$(srcdir)/../libdwarf -I..
+
+ YACC = @YACC@ -d
+--- elfutils-0.89/./tests/Makefile.am~warnings.patch 2003-08-13 05:19:04.000000000 -0400
++++ elfutils-0.89/./tests/Makefile.am 2004-05-01 00:12:43.000000000 -0400
+@@ -14,7 +14,6 @@
+ ## 3001 King Ranch Road, Ukiah, CA 95482.
+ ##
+ DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
+-AM_CFLAGS = -Wall -Werror
+ AM_LDFLAGS = -Wl,-rpath,\$$ORIGIN/../libasm:\$$ORIGIN/../libdwarf:\$$ORIGIN/../libdw:\$$ORIGIN/../libebl:\$$ORIGIN/../libelf
+ INCLUDES = -I$(top_srcdir)/libasm -I$(top_srcdir)/libdwarf \
+ -I$(top_srcdir)/libdw \
diff --git a/recipes/elfutils/elfutils_0.127.bb b/recipes/elfutils/elfutils_0.127.bb
new file mode 100644
index 0000000000..22f3b0ae46
--- /dev/null
+++ b/recipes/elfutils/elfutils_0.127.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
+SECTION = "base"
+LICENSE = "OSL"
+DEPENDS = "libtool"
+
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/elfutils-${PV}.tar.gz \
+ file://warnings.patch;patch=1"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/elfutils/elfutils_0.131.bb b/recipes/elfutils/elfutils_0.131.bb
new file mode 100644
index 0000000000..22f3b0ae46
--- /dev/null
+++ b/recipes/elfutils/elfutils_0.131.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
+SECTION = "base"
+LICENSE = "OSL"
+DEPENDS = "libtool"
+
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/elfutils-${PV}.tar.gz \
+ file://warnings.patch;patch=1"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/elfutils/elfutils_0.89.bb b/recipes/elfutils/elfutils_0.89.bb
new file mode 100644
index 0000000000..aad2275ef9
--- /dev/null
+++ b/recipes/elfutils/elfutils_0.89.bb
@@ -0,0 +1,43 @@
+SECTION = "base"
+LICENSE = "OSL"
+DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
+DEPENDS = "libtool"
+
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/elfutils-${PV}.tar.gz \
+ file://warnings.patch;patch=1"
+
+inherit autotools
+
+SOV = "${PV}"
+do_stage () {
+ install -m 0644 libelf/libelf.a ${STAGING_LIBDIR}/libelf.a
+ install -m 0755 libelf/libelf.so.1 ${STAGING_LIBDIR}/libelf-${SOV}.so
+ ln -sf libelf-${SOV}.so ${STAGING_LIBDIR}/libelf.so.1
+ ln -sf libelf.so.1 ${STAGING_LIBDIR}/libelf.so
+ install -m 0644 libasm/libasm.a ${STAGING_LIBDIR}/libasm.a
+ install -m 0755 libasm/libasm.so.1 ${STAGING_LIBDIR}/libasm-${SOV}.so
+ ln -sf libasm-${SOV}.so ${STAGING_LIBDIR}/libasm.so.1
+ ln -sf libasm.so.1 ${STAGING_LIBDIR}/libasm.so
+ install -m 0644 libdw/libdw.a ${STAGING_LIBDIR}/libdw.a
+ install -m 0755 libdw/libdw.so.1 ${STAGING_LIBDIR}/libdw-${SOV}.so
+ ln -sf libdw-${SOV}.so ${STAGING_LIBDIR}/libdw.so.1
+ ln -sf libdw.so.1 ${STAGING_LIBDIR}/libdw.so
+ install -m 0644 libebl/libebl.a ${STAGING_LIBDIR}/libebl.a
+ install -d ${STAGING_LIBDIR}/elfutils/
+ install -m 0755 libebl/libebl_*.so ${STAGING_LIBDIR}/elfutils/
+ install -m 0644 libdwarf/libdwarf.a ${STAGING_LIBDIR}/libdwarf.a
+ install -m 0755 libdwarf/libdwarf.so.1 ${STAGING_LIBDIR}/libdwarf-${SOV}.so
+ ln -sf libdwarf-${SOV}.so ${STAGING_LIBDIR}/libdwarf.so.1
+ ln -sf libdwarf.so.1 ${STAGING_LIBDIR}/libdwarf.so
+
+ install -m 0644 ${S}/libelf/libelf.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/libelf/gelf.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/libelf/nlist.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/libdwarf/dwarf.h ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}/elfutils
+ install -m 0644 ${S}/libebl/libebl.h ${STAGING_INCDIR}/elfutils/
+ install -m 0644 ${S}/libebl/elf-knowledge.h ${STAGING_INCDIR}/elfutils/
+ install -m 0644 ${S}/libdwarf/libdwarf.h ${STAGING_INCDIR}/elfutils/
+ install -m 0644 ${S}/libdw/libdw.h ${STAGING_INCDIR}/elfutils/
+ install -m 0644 ${S}/libasm/libasm.h ${STAGING_INCDIR}/elfutils/
+}