summaryrefslogtreecommitdiffstats
path: root/recipes/em8300
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/em8300
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/em8300')
-rw-r--r--recipes/em8300/em8300_0.16.3.bb47
-rw-r--r--recipes/em8300/files/kernel-source-dir.diff11
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes/em8300/em8300_0.16.3.bb b/recipes/em8300/em8300_0.16.3.bb
new file mode 100644
index 0000000000..11c69f52ad
--- /dev/null
+++ b/recipes/em8300/em8300_0.16.3.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Drivers and utils for DXR3/Hollywood+ mpeg decoder cards""
+DEPENDS = "gtk+"
+
+# Be sure to have the I2C bitbanging interface enabled in your kernel config
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/dxr3/${PN}-${PV}.tar.gz \
+ file://kernel-source-dir.diff;patch=1 \
+ "
+
+inherit module-base autotools
+
+do_configure_prepend() {
+ sed -i -e s:SEDME:${STAGING_KERNEL_DIR}:g modules/Makefile
+}
+
+do_compile_append() {
+ cd ${S}/modules
+ oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
+ KERNEL_SRC=${STAGING_KERNEL_DIR} \
+ KERNEL_VERSION=${KERNEL_VERSION} \
+ CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+ cd ${S}
+}
+
+do_install_append() {
+ cd ${S}/modules
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" CC="${KERNEL_CC}" LD="${KERNEL_LD}" modules_install
+ cd ${S}
+}
+
+PACKAGES =+ "em8300-modules"
+FILES_em8300-modules = "${base_libdir}/modules"
+
+pkg_postinst_append () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm_append () {
+ update-modules || true
+}
+
+
diff --git a/recipes/em8300/files/kernel-source-dir.diff b/recipes/em8300/files/kernel-source-dir.diff
new file mode 100644
index 0000000000..c7ae68a792
--- /dev/null
+++ b/recipes/em8300/files/kernel-source-dir.diff
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2007-12-26 20:28:11.474790960 +0100
++++ em8300-0.16.3/modules/Makefile 2007-12-26 20:28:57.938122985 +0100
+@@ -19,7 +19,7 @@
+
+ ifeq ($(KERNELRELEASE),)
+
+-KERNEL_LOCATION := /lib/modules/$(shell uname -r)/build
++KERNEL_LOCATION = SEDME
+
+ # If you are using external i2c modules, you should set
+ # EM8300_I2C_LOCATION to the source directory of the modules.