aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/emacs/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/emacs/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/emacs/files')
-rw-r--r--recipes/emacs/files/nostdlib-unwind.patch16
-rw-r--r--recipes/emacs/files/use-qemu.patch80
2 files changed, 96 insertions, 0 deletions
diff --git a/recipes/emacs/files/nostdlib-unwind.patch b/recipes/emacs/files/nostdlib-unwind.patch
new file mode 100644
index 0000000000..4200301a3f
--- /dev/null
+++ b/recipes/emacs/files/nostdlib-unwind.patch
@@ -0,0 +1,16 @@
+Fix linking problem:
+undefined reference to `__aeabi_unwind_cpp_pr0'
+undefined reference to `__aeabi_unwind_cpp_pr1'
+Index: emacs/src/Makefile.in
+===================================================================
+--- emacs.orig/src/Makefile.in 2008-08-16 14:20:18.000000000 +0000
++++ emacs/src/Makefile.in 2008-08-16 14:51:25.000000000 +0000
+@@ -443,7 +443,7 @@
+ ask GCC explicitly where to find libgcc.a. */
+
+ #ifndef LINKER
+-#define LINKER $(CC) -nostdlib
++#define LINKER $(CC) -nostdlib -lgcc_s
+ #endif
+
+ #ifndef LIB_GCC
diff --git a/recipes/emacs/files/use-qemu.patch b/recipes/emacs/files/use-qemu.patch
new file mode 100644
index 0000000000..f27c926e3e
--- /dev/null
+++ b/recipes/emacs/files/use-qemu.patch
@@ -0,0 +1,80 @@
+diff -Nur emacs~/Makefile.in emacs/Makefile.in
+--- emacs~/Makefile.in 2006-07-25 09:45:48.000000000 -0700
++++ emacs/Makefile.in 2006-07-26 07:33:43.000000000 -0700
+@@ -782,7 +782,7 @@
+ bootstrap-build: FRC
+ (cd lisp; $(MAKE) $(MFLAGS) bootstrap-prepare)
+ (cd src; $(MAKE) $(MFLAGS) bootstrap)
+- (cd lisp; $(MAKE) $(MFLAGS) bootstrap EMACS=../src/bootstrap-emacs${EXEEXT})
++ (cd lisp; $(MAKE) $(MFLAGS) bootstrap EMACS="${QEMU} ../src/bootstrap-emacs${EXEEXT}")
+ (cd src; $(MAKE) $(MFLAGS) mostlyclean)
+ $(MAKE) $(MFLAGS) all
+ (cd lisp; $(MAKE) $(MFLAGS) bootstrap-after)
+diff -Nur emacs~/leim/Makefile.in emacs/leim/Makefile.in
+--- emacs~/leim/Makefile.in 2006-07-25 09:45:53.000000000 -0700
++++ emacs/leim/Makefile.in 2006-07-26 07:30:53.000000000 -0700
+@@ -48,7 +48,7 @@
+
+ # How to run Emacs.
+ RUN-EMACS = EMACSLOADPATH=$(buildlisppath) LC_ALL=C\
+- ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte
++ ${QEMU} ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte
+
+ # Subdirectories to be made if ${srcdir} is different from the current
+ # directory.
+diff -Nur emacs~/lib-src/Makefile.in emacs/lib-src/Makefile.in
+--- emacs~/lib-src/Makefile.in 2006-07-25 09:45:54.000000000 -0700
++++ emacs/lib-src/Makefile.in 2006-07-26 07:36:29.000000000 -0700
+@@ -380,7 +380,7 @@
+ clobbered too. */
+ test-distrib${EXEEXT}: ${srcdir}/test-distrib.c
+ $(CC) ${ALL_CFLAGS} -o test-distrib ${srcdir}/test-distrib.c
+- ./test-distrib ${srcdir}/testfile
++ ${QEMU} ./test-distrib ${srcdir}/testfile
+
+ /* We need the following in order to create a <getopt.h> when the system
+ doesn't have one that works with the given compiler. */
+diff -Nur emacs~/lisp/Makefile.in emacs/lisp/Makefile.in
+--- emacs~/lisp/Makefile.in 2006-07-25 09:45:55.000000000 -0700
++++ emacs/lisp/Makefile.in 2006-07-26 14:09:59.000000000 -0700
+@@ -28,7 +28,7 @@
+ # You can specify a different executable on the make command line,
+ # e.g. "make EMACS=../src/emacs ...".
+
+-EMACS = ../src/emacs
++EMACS = ${QEMU} ../src/emacs
+
+ # Command line flags for Emacs. This must include --multibyte,
+ # otherwise some files will not compile.
+diff -Nur emacs~/src/Makefile.in emacs/src/Makefile.in
+--- emacs~/src/Makefile.in 2006-07-25 09:46:16.000000000 -0700
++++ emacs/src/Makefile.in 2006-07-26 07:37:44.000000000 -0700
+@@ -491,7 +491,7 @@
+ this with the shell's `for' construct.
+ Note that some people don't have '.' in their paths, so we must
+ use ./prefix-args. */
+-#define YMF_PASS_LDFLAGS(flags) `./prefix-args -Xlinker flags`
++#define YMF_PASS_LDFLAGS(flags) `${QEMU} ./prefix-args -Xlinker flags`
+ #else
+ #define YMF_PASS_LDFLAGS(flags) flags
+ #endif
+@@ -943,7 +943,7 @@
+ #define OBJECTS_MACHINE
+ #endif
+
+-RUN_TEMACS = ./temacs
++RUN_TEMACS = ${QEMU} ./temacs
+
+ all: emacs${EXEEXT} OTHER_FILES
+
+@@ -970,8 +970,8 @@
+ Likewise for ${SOME_MACHINE_LISP}. */
+ ${etc}DOC: ${libsrc}make-docfile${EXEEXT} ${obj} ${shortlisp} ${SOME_MACHINE_LISP}
+ -rm -f ${etc}DOC
+- ${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC
+- ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp}
++ ${QEMU} ${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC
++ ${QEMU} ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp}
+
+ ${libsrc}make-docfile${EXEEXT}:
+ cd ${libsrc}; ${MAKE} ${MFLAGS} make-docfile${EXEEXT}