aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/emul
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/emul
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/emul')
-rw-r--r--recipes/emul/emul_1.0.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/emul/emul_1.0.5.bb b/recipes/emul/emul_1.0.5.bb
new file mode 100644
index 0000000000..261c604b91
--- /dev/null
+++ b/recipes/emul/emul_1.0.5.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "EarthMate Userland Library"
+SECTION = "libs/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libusb ncurses"
+PR = "r1"
+
+SRC_URI = "http://download.berlios.de/emul/emul-${PV}.tar.gz"
+
+CFLAGS += "-I${STAGING_INCDIR}"
+
+do_compile() {
+ ${CC} -c ${CFLAGS} -D_REENTRANT -fPIC -o emul.o src/emul.c
+ ${CC} -c ${CFLAGS} -D_REENTRANT -fPIC -o buf.o src/buf.c
+ ${CC} ${LDFLAGS} -shared -fPIC -Wl,-soname,libemul.so.1 -o libemul.so -lusb -lpthread emul.o buf.o
+
+ ${CC} -c ${CFLAGS} -Isrc -o sirfmon.o src/sirfmon.c
+ ${CC} ${LDFLAGS} -L. -lemul -lncurses -lm sirfmon.o -o sirfmon
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ oe_libinstall -so libemul ${D}${libdir}
+
+ install -d ${D}${bindir}
+ install -m 0755 sirfmon ${D}${bindir}
+}
+
+PACKAGES =+ "sirfmon"
+SECTION_sirfmon = "network"
+FILES_sirfmon = "${bindir}"
+FILES_${PN} = "${libdir}"