aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enca
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/enca
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/enca')
-rw-r--r--recipes/enca/enca_1.9.bb31
-rw-r--r--recipes/enca/files/configure-hack.patch12
-rw-r--r--recipes/enca/files/configure-remove-dumbness.patch26
-rw-r--r--recipes/enca/files/dont-run-tests.patch13
-rw-r--r--recipes/enca/files/makefile-remove-tools.patch13
5 files changed, 95 insertions, 0 deletions
diff --git a/recipes/enca/enca_1.9.bb b/recipes/enca/enca_1.9.bb
new file mode 100644
index 0000000000..548a824523
--- /dev/null
+++ b/recipes/enca/enca_1.9.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Enca is an Extremely Naive Charset Analyser"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://trific.ath.cx/software/enca/"
+PR = "r3"
+
+SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
+ file://configure-hack.patch;patch=1 \
+ file://dont-run-tests.patch;patch=1 \
+ file://configure-remove-dumbness.patch;patch=1 \
+ file://makefile-remove-tools.patch;patch=1 "
+
+inherit autotools
+
+EXTRA_OECONF="--with-libiconv-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+do_configure_append() {
+ sed -i s:-I/usr/include::g Makefile
+ sed -i s:-I/usr/include::g */Makefile
+}
+
+do_compile() {
+ cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
+ cd ..
+ oe_runmake
+}
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/enca/files/configure-hack.patch b/recipes/enca/files/configure-hack.patch
new file mode 100644
index 0000000000..85abcdcf02
--- /dev/null
+++ b/recipes/enca/files/configure-hack.patch
@@ -0,0 +1,12 @@
+--- enca-1.9/configure.ac.orig 2006-02-15 00:57:39.000000000 -0800
++++ enca-1.9/configure.ac 2006-02-15 00:57:46.000000000 -0800
+@@ -92,9 +92,6 @@
+ dnl And for gtk-doc
+ gtk_CHECK_GTK_DOC
+
+-dnl Check for good random number sources
+-AC_CHECK_FILES(/dev/random /dev/urandom /dev/srandom /dev/arandom)
+-
+ dnl Dirty path hack. Helps some people with badly set up search paths.
+ if test "$prefix" = "NONE"; then
+ LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
diff --git a/recipes/enca/files/configure-remove-dumbness.patch b/recipes/enca/files/configure-remove-dumbness.patch
new file mode 100644
index 0000000000..6f6f3e320e
--- /dev/null
+++ b/recipes/enca/files/configure-remove-dumbness.patch
@@ -0,0 +1,26 @@
+--- enca-1.9/configure.ac.orig 2006-06-29 15:30:44.000000000 +0100
++++ enca-1.9/configure.ac 2006-06-29 15:31:41.000000000 +0100
+@@ -92,14 +92,15 @@
+ dnl And for gtk-doc
+ gtk_CHECK_GTK_DOC
+
+-dnl Dirty path hack. Helps some people with badly set up search paths.
+-if test "$prefix" = "NONE"; then
+- LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
+-else
+- LDFLAGS="$LDFLAGS -L$prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-fi
++# This is really dumb code
++#dnl Dirty path hack. Helps some people with badly set up search paths.
++#if test "$prefix" = "NONE"; then
++# LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
++# CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
++#else
++# LDFLAGS="$LDFLAGS -L$prefix/lib"
++# CPPFLAGS="$CPPFLAGS -I$prefix/include"
++#fi
+
+ dnl Checks for libraries.
+ ye_CHECK_LIBM
diff --git a/recipes/enca/files/dont-run-tests.patch b/recipes/enca/files/dont-run-tests.patch
new file mode 100644
index 0000000000..321d1e6201
--- /dev/null
+++ b/recipes/enca/files/dont-run-tests.patch
@@ -0,0 +1,13 @@
+Index: enca-1.9/Makefile.am
+===================================================================
+--- enca-1.9.orig/Makefile.am 2005-11-24 11:21:32.000000000 +0100
++++ enca-1.9/Makefile.am 2006-04-11 11:14:21.832502904 +0200
+@@ -2,7 +2,7 @@
+ if MAINTAINER_MODE
+ SUBDIRS = tools data script lib src devel-docs test
+ else
+-SUBDIRS = tools script lib src devel-docs test
++SUBDIRS = tools script lib src devel-docs
+ endif
+ man_MANS = man/enca.1
+
diff --git a/recipes/enca/files/makefile-remove-tools.patch b/recipes/enca/files/makefile-remove-tools.patch
new file mode 100644
index 0000000000..accfbccd6b
--- /dev/null
+++ b/recipes/enca/files/makefile-remove-tools.patch
@@ -0,0 +1,13 @@
+--- enca-1.9/Makefile.am.orig 2006-06-29 15:34:55.000000000 +0100
++++ enca-1.9/Makefile.am 2006-06-29 15:35:20.000000000 +0100
+@@ -1,8 +1,8 @@
+ # @(#) $Id: Makefile.am,v 1.35 2005/11/24 10:21:32 yeti Exp $
+ if MAINTAINER_MODE
+-SUBDIRS = tools data script lib src devel-docs test
++SUBDIRS = data script lib src devel-docs test
+ else
+-SUBDIRS = tools script lib src devel-docs
++SUBDIRS = script lib src devel-docs
+ endif
+ man_MANS = man/enca.1
+