aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enchant
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/enchant
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/enchant')
-rw-r--r--recipes/enchant/enchant_1.1.3.bb2
-rw-r--r--recipes/enchant/enchant_1.2.5.bb2
-rw-r--r--recipes/enchant/enchant_1.3.0.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/enchant/enchant_1.1.3.bb b/recipes/enchant/enchant_1.1.3.bb
index 0663f219c9..5556e7846b 100644
--- a/recipes/enchant/enchant_1.1.3.bb
+++ b/recipes/enchant/enchant_1.1.3.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "libs"
DEPENDS = "aspell"
-RDEPENDS = "aspell"
+RDEPENDS_${PN} = "aspell"
inherit autotools pkgconfig
diff --git a/recipes/enchant/enchant_1.2.5.bb b/recipes/enchant/enchant_1.2.5.bb
index 7713a9dfa1..5537ae2331 100644
--- a/recipes/enchant/enchant_1.2.5.bb
+++ b/recipes/enchant/enchant_1.2.5.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "libs"
LICENSE = "LGPL"
DEPENDS = "aspell"
-RDEPENDS = "aspell"
+RDEPENDS_${PN} = "aspell"
inherit autotools pkgconfig
diff --git a/recipes/enchant/enchant_1.3.0.bb b/recipes/enchant/enchant_1.3.0.bb
index 7349762b80..bb11cb7015 100644
--- a/recipes/enchant/enchant_1.3.0.bb
+++ b/recipes/enchant/enchant_1.3.0.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "libs"
LICENSE = "LGPL"
DEPENDS = "aspell glib-2.0"
-RDEPENDS = "aspell"
+RDEPENDS_${PN} = "aspell"
inherit autotools pkgconfig