aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enchant
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/enchant
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/enchant')
-rw-r--r--recipes/enchant/enchant_1.1.3.bb23
-rw-r--r--recipes/enchant/enchant_1.2.5.bb28
-rw-r--r--recipes/enchant/enchant_1.3.0.bb24
-rw-r--r--recipes/enchant/files/configure.patch10
4 files changed, 85 insertions, 0 deletions
diff --git a/recipes/enchant/enchant_1.1.3.bb b/recipes/enchant/enchant_1.1.3.bb
new file mode 100644
index 0000000000..7618c5d3ee
--- /dev/null
+++ b/recipes/enchant/enchant_1.1.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+PRIORITY = "optional"
+SECTION = "libs"
+
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://download.sourceforge.net/abiword/enchant-1.1.3.tar.gz"
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR_HOST}${layout_prefix} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR_HOST}${layout_mandir}
+}
diff --git a/recipes/enchant/enchant_1.2.5.bb b/recipes/enchant/enchant_1.2.5.bb
new file mode 100644
index 0000000000..be9082d2af
--- /dev/null
+++ b/recipes/enchant/enchant_1.2.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+PRIORITY = "optional"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r1"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
+
+FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR_HOST}${layout_prefix} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR_HOST}${layout_mandir}
+}
diff --git a/recipes/enchant/enchant_1.3.0.bb b/recipes/enchant/enchant_1.3.0.bb
new file mode 100644
index 0000000000..cceceebabf
--- /dev/null
+++ b/recipes/enchant/enchant_1.3.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+PRIORITY = "optional"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
+
+export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
+
+FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/enchant/files/configure.patch b/recipes/enchant/files/configure.patch
new file mode 100644
index 0000000000..6f1f23e01d
--- /dev/null
+++ b/recipes/enchant/files/configure.patch
@@ -0,0 +1,10 @@
+--- enchant-1.2.5/configure.in.orig 2006-04-14 11:08:20.000000000 +0100
++++ enchant-1.2.5/configure.in 2006-04-14 11:12:03.000000000 +0100
+@@ -147,6 +147,7 @@
+ LDFLAGS="-L$with_aspell_prefix/lib "$LDFLAGS
+ ASPELL_INC="-I$with_aspell_prefix/include"
+ ASPELL_LIBS="-L$with_aspell_prefix/lib -laspell"
++ aspell_prefix=$with_aspell_prefix
+ else
+ aspell_prefix=${prefix}
+ if test "x$prefix" = "xNONE"; then