aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/epdfview
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-09-18 10:12:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-08 07:34:33 +0100
commitfb55f52daad5c8f12a6c8a40a1ff2977b7dd6b6b (patch)
tree1b736705c6ccccf7c960519f90a82587587e2eb5 /recipes/epdfview
parent9b641bbfed07c075ae5cbe84082a85f1ba703447 (diff)
downloadopenembedded-fb55f52daad5c8f12a6c8a40a1ff2977b7dd6b6b.tar.gz
epdfview: add icon for shr and recipe for svn version
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/epdfview')
-rw-r--r--recipes/epdfview/epdfview_0.1.7.bb15
-rw-r--r--recipes/epdfview/epdfview_svn.bb37
-rw-r--r--recipes/epdfview/files/acroread.pngbin0 -> 7670 bytes
3 files changed, 51 insertions, 1 deletions
diff --git a/recipes/epdfview/epdfview_0.1.7.bb b/recipes/epdfview/epdfview_0.1.7.bb
index 1cd59f7394..fd1b61f7f5 100644
--- a/recipes/epdfview/epdfview_0.1.7.bb
+++ b/recipes/epdfview/epdfview_0.1.7.bb
@@ -5,7 +5,10 @@ SECTION = "x11/applications"
DEPENDS = "poppler gtk+ cups"
SRC_URI = "http://www.emma-soft.com/projects/epdfview/chrome/site/releases/epdfview-${PV}.tar.bz2 \
- "
+ "
+
+SRC_URI_append_shr = "file://acroread.png \
+ "
inherit autotools
@@ -13,3 +16,13 @@ do_compile_append () {
sed -i 's|\$.*prefix./|/usr/|' data/epdfview.desktop
}
+do_compile_append_shr () {
+ sed -i 's/Icon=.*/Icon=acroread/' data/epdfview.desktop
+}
+
+do_install_append_shr () {
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/acroread.png ${D}${datadir}/pixmaps/
+}
+
+FILES_${PN}_append_shr = "${datadir}/pixmaps/acroread.png" \ No newline at end of file
diff --git a/recipes/epdfview/epdfview_svn.bb b/recipes/epdfview/epdfview_svn.bb
new file mode 100644
index 0000000000..1c8e9e9453
--- /dev/null
+++ b/recipes/epdfview/epdfview_svn.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "A minimal PDF viewer based on gtk and poppler"
+HOMEPAGE = "http://www.emma-soft.com/projects/epdfview/"
+LICENSE = "GPLv2"
+SECTION = "x11/applications"
+DEPENDS = "poppler gtk+ cups"
+
+PV = "0.1.7+svnr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.emma-soft.com/epdfview;module=trunk;proto=svn \
+ "
+SRC_URI_append_shr = "file://acroread.png \
+ "
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+do_configure_prepend() {
+ sh autogen.sh
+}
+
+do_compile_append () {
+ sed -i 's|\$.*prefix./|/usr/|' data/epdfview.desktop
+}
+
+do_compile_append_shr () {
+ sed -i 's/Icon=.*/Icon=acroread/' data/epdfview.desktop
+}
+
+do_install_append_shr () {
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/acroread.png ${D}${datadir}/pixmaps/
+}
+
+FILES_${PN}_append_shr = "${datadir}/pixmaps/acroread.png \
+ "
diff --git a/recipes/epdfview/files/acroread.png b/recipes/epdfview/files/acroread.png
new file mode 100644
index 0000000000..0189fe3072
--- /dev/null
+++ b/recipes/epdfview/files/acroread.png
Binary files differ