aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/espeak
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2010-06-20 14:35:05 -0700
committerChris Larson <chris_larson@mentor.com>2010-07-26 10:59:36 -0700
commit87dc166bade8722af4076c8644cac6a0a437826f (patch)
treee52609ad65bb807cd6856cbe95c2f28783000618 /recipes/espeak
parentc47c6611be11d3b80f61a75f80187e9398eccbd4 (diff)
downloadopenembedded-87dc166bade8722af4076c8644cac6a0a437826f.tar.gz
Siteinfo cleanup
- Don't supply site files for native - Split up the site information, so we don't need to add every single combination of os and architecture to the siteinfo.bbclass - Instead of specifically looking for '${FILE_DIRNAME}/site-${PV}/<sitefile>', leverage FILESPATH. Now it searches the paths in both BBPATH and FILESPATH for "site/<sitefile>". - SITEINFO_ENDIANESS -> SITEINFO_ENDIANNESS Signed-off-by: Chris Larson <clarson@kergoth.com>
Diffstat (limited to 'recipes/espeak')
-rw-r--r--recipes/espeak/espeak_1.37.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/espeak/espeak_1.37.bb b/recipes/espeak/espeak_1.37.bb
index fb94bd347e..37af83d89d 100644
--- a/recipes/espeak/espeak_1.37.bb
+++ b/recipes/espeak/espeak_1.37.bb
@@ -1,7 +1,7 @@
require espeak.inc
inherit siteinfo
-EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be", "espeak-data (= ${PV})", "", d)}'
+EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}'
RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
PR = "r0"
@@ -32,7 +32,7 @@ do_install() {
install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
oe_libinstall -so -C src libespeak ${D}${libdir}
- if [ "${SITEINFO_ENDIANESS}" = "be" ] ; then
+ if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
# the big-endian phon* files are provided by the package espeak-data
rm -f ${S}/espeak-data/phon*
fi