aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/etherpuppet
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/etherpuppet
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/etherpuppet')
-rw-r--r--recipes/etherpuppet/etherpuppet_0.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/etherpuppet/etherpuppet_0.2.bb b/recipes/etherpuppet/etherpuppet_0.2.bb
new file mode 100644
index 0000000000..0f3150e8e4
--- /dev/null
+++ b/recipes/etherpuppet/etherpuppet_0.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Etherpuppet is a small program for Linux that will create a \
+voodoo doll for an Ethernet interface. You have to run the Etherpuppet on \
+your machine to create the doll, which will have the shape of a virtual \
+TUN/TAP interface (named by default puppet%d, where %d is a number). \
+You also have to run Etherpuppet on the victim interface's machine."
+SECTION = "console/network"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.secdev.org/projects/etherpuppet/files/etherpuppet.c"
+S = "${WORKDIR}"
+
+do_unpack() {
+ install -m 0644 ${DL_DIR}/etherpuppet.c ${S}
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LFLAGS} -o etherpuppet etherpuppet.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 etherpuppet ${D}${sbindir}
+}
+