aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ettercap/files
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-23 15:57:37 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-23 16:07:34 +0800
commit86a524db965a46b1262d6f0ffcec1954cff4c5c0 (patch)
tree7b24fbfda36fe3a2043c954854aa707bf051f010 /recipes/ettercap/files
parentc73ddd13c8eb7ee231b69af0312341cf227b102d (diff)
downloadopenembedded-86a524db965a46b1262d6f0ffcec1954cff4c5c0.tar.gz
ettercap-ng: Attempt to unbreak the build with a recent libtool
The variable for the plugin extension appears to have changed, at least this value is "so" so it should work on the device.
Diffstat (limited to 'recipes/ettercap/files')
-rw-r--r--recipes/ettercap/files/configure.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/ettercap/files/configure.patch b/recipes/ettercap/files/configure.patch
new file mode 100644
index 0000000000..4a6a5e3bfc
--- /dev/null
+++ b/recipes/ettercap/files/configure.patch
@@ -0,0 +1,27 @@
+Index: ettercap-NG-0.7.3/configure.in
+===================================================================
+--- ettercap-NG-0.7.3.orig/configure.in 2010-03-23 15:41:37.021090022 +0800
++++ ettercap-NG-0.7.3/configure.in 2010-03-23 15:43:52.594188005 +0800
+@@ -198,6 +198,9 @@
+ dnl Libtool related...
+ dnl ========================
+
++LT_INIT
++LTDL_INIT
++LT_CONFIG_LTDL_DIR([libltdl])
+ AC_DISABLE_STATIC
+ AC_LIBTOOL_WIN32_DLL
+ AC_LIBTOOL_DLOPEN
+Index: ettercap-NG-0.7.3/src/ec_plugins.c
+===================================================================
+--- ettercap-NG-0.7.3.orig/src/ec_plugins.c 2010-03-23 15:47:32.371100910 +0800
++++ ettercap-NG-0.7.3/src/ec_plugins.c 2010-03-23 15:48:20.644990548 +0800
+@@ -131,7 +131,7 @@
+ int plugin_filter(const struct dirent *d)
+ #endif
+ {
+- if ( match_pattern(d->d_name, PLUGIN_PATTERN LTDL_SHLIB_EXT) )
++ if ( match_pattern(d->d_name, PLUGIN_PATTERN LT_MODULE_EXT) )
+ return 1;
+
+ return 0;