aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/evince/evince
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-17 13:29:41 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-17 15:40:25 -0700
commitb2c2771ddc0e5ddc307999a9a63c5bade88d5956 (patch)
tree1a2cf08e69e64b6dbf15e62088ae08a54d1f548b /recipes/evince/evince
parent281aa0c3d1ddaf69e15174ae145709ce38c3b89d (diff)
downloadopenembedded-b2c2771ddc0e5ddc307999a9a63c5bade88d5956.tar.gz
evince_2.30.0.bb: Make pkg-config to construct right paths.
* pkg-config has nice option PKG_CONFIG_SYSROOT_DIR for cross compiling but its only for include and libraries it is ignored for other things pkg-config provides. * this fixes the needed. There may be more places that needs same fix. For us this one suffices for now. * Add gnome-doc-utils-native to DEPENDS. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/evince/evince')
-rw-r--r--recipes/evince/evince/cross-compile-fix.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/evince/evince/cross-compile-fix.patch b/recipes/evince/evince/cross-compile-fix.patch
new file mode 100644
index 0000000000..d99b6750b6
--- /dev/null
+++ b/recipes/evince/evince/cross-compile-fix.patch
@@ -0,0 +1,24 @@
+Index: evince-2.30.0/gnome-doc-utils.make
+===================================================================
+--- evince-2.30.0.orig/gnome-doc-utils.make 2010-03-29 11:52:47.000000000 -0700
++++ evince-2.30.0/gnome-doc-utils.make 2010-08-17 15:20:22.597646001 -0700
+@@ -132,13 +132,12 @@ _DOC_ABS_SRCDIR = @abs_srcdir@
+
+ _xml2po ?= `which xml2po`
+ _xml2po_mode = $(if $(DOC_ID),mallard,docbook)
+-
+-_db2html ?= `$(PKG_CONFIG) --variable db2html gnome-doc-utils`
+-_db2omf ?= `$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
+-_malrng ?= `$(PKG_CONFIG) --variable malrng gnome-doc-utils`
+-_chunks ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
+-_credits ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
+-_ids ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/ids.xsl
++_db2html ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2html gnome-doc-utils`
++_db2omf ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
++_malrng ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable malrng gnome-doc-utils`
++_chunks ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
++_credits ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
++_ids ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/ids.xsl
+
+ if ENABLE_SK
+ _ENABLE_SK = true