summaryrefslogtreecommitdiffstats
path: root/recipes/exalt
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-04 10:45:23 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-04 11:27:18 +0100
commit8ac85f656c678b4e0cb458e8e5876f4c37756eff (patch)
treec44d04c178875ad350583bc1b0b2fc05b8156b31 /recipes/exalt
parent4dcaca2917c61d8858e4a86ed84f32435e119c79 (diff)
downloadopenembedded-8ac85f656c678b4e0cb458e8e5876f4c37756eff.tar.gz
exalt: update to current form
Diffstat (limited to 'recipes/exalt')
-rw-r--r--recipes/exalt/exalt-daemon/init37
-rw-r--r--recipes/exalt/exalt-daemon_svn.bb13
-rw-r--r--recipes/exalt/exalt-module/autotools-fix.patch12
-rw-r--r--recipes/exalt/exalt-module_svn.bb19
-rw-r--r--recipes/exalt/exalt.inc12
-rw-r--r--recipes/exalt/exalt_svn.bb4
-rw-r--r--recipes/exalt/libexalt-dbus_svn.bb9
-rw-r--r--recipes/exalt/libexalt_svn.bb8
8 files changed, 0 insertions, 114 deletions
diff --git a/recipes/exalt/exalt-daemon/init b/recipes/exalt/exalt-daemon/init
deleted file mode 100644
index cbceed1793..0000000000
--- a/recipes/exalt/exalt-daemon/init
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-set -e
-
-#need dbus and hald
-
-start() {
- echo -n "Starting Exalt daemon..."
- start-stop-daemon --start --exec /usr/sbin/exalt-daemon \
- --pidfile /var/run/exaltd.pid
- echo "done."
-}
-
-stop() {
- echo -n "Stopping Exalt daemon..."
- start-stop-daemon --stop --exec /usr/sbin/exalt-daemon \
- --pidfile /var/run/exaltd.pid
- echo "done."
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- stop
- sleep 2
- start
- ;;
- *)
- echo "Usage: $(basename $0) {start|stop|restart}"
- exit 1
-esac
-
-exit 0
diff --git a/recipes/exalt/exalt-daemon_svn.bb b/recipes/exalt/exalt-daemon_svn.bb
deleted file mode 100644
index 8f5e9afa29..0000000000
--- a/recipes/exalt/exalt-daemon_svn.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require exalt.inc
-
-DEPENDS = "evas edbus libexalt"
-
-SRC_URI += "file://init"
-
-do_install_append() {
- install -D -m 0755 "${WORKDIR}/init" "${D}${sysconfdir}/dbus-1/event.d/40exaltd"
-}
-
-FILES_${PN} += "${sysconfdir}/dbus-1/event.d/"
-
-EXALT_MODULE = "daemon"
diff --git a/recipes/exalt/exalt-module/autotools-fix.patch b/recipes/exalt/exalt-module/autotools-fix.patch
deleted file mode 100644
index 8f3b3deb51..0000000000
--- a/recipes/exalt/exalt-module/autotools-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: module/Makefile.am
-===================================================================
---- module.orig/Makefile.am 2008-04-16 17:39:03.000000000 +0800
-+++ module/Makefile.am 2008-04-16 17:39:05.000000000 +0800
-@@ -26,7 +26,6 @@
- # the module .so file
- INCLUDES = -I. \
- -I$(top_srcdir) \
-- -I$(includedir) \
- @EXALT_CFLAGS@ \
- @e_cflags@
-
diff --git a/recipes/exalt/exalt-module_svn.bb b/recipes/exalt/exalt-module_svn.bb
deleted file mode 100644
index 0a28a1a206..0000000000
--- a/recipes/exalt/exalt-module_svn.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-require exalt.inc
-
-DEPENDS = "edbus libexalt-dbus"
-RDEPENDS_${PN} = "exalt"
-
-SRC_URI += "file://autotools-fix.patch;patch=1;minrev=78"
-
-EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
-
-FILES_${PN} += "${libdir}/enlightenment/modules/module_exalt/*.edj \
- ${libdir}/enlightenment/modules/module_exalt/*/*.so \
- ${libdir}/enlightenment/modules/module_exalt/*.desktop \
- ${libdir}/enlightenment/modules/module_exalt/module_exalt"
-FILES_${PN}-dev += "${libdir}/enlightenment/modules/module_exalt/*/*.a \
- ${libdir}/enlightenment/modules/module_exalt/*/*.la"
-FILES_${PN}-dbg += "${libdir}/enlightenment/modules/module_exalt/*/.debug"
-FILES_${PN}-locale += "${libdir}/enlightenment/modules/module_exalt/locale"
-
-EXALT_MODULE = "module"
diff --git a/recipes/exalt/exalt.inc b/recipes/exalt/exalt.inc
deleted file mode 100644
index 2e82be2d82..0000000000
--- a/recipes/exalt/exalt.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
-AUTHOR = "John Lee <john_lee@openmoko.com>"
-HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
-PV = "0.0.0+svnr${SRCREV}"
-
-SRC_URI = "svn://svn.berlios.de/exalt/trunk;module=${EXALT_MODULE};proto=svn"
-
-S = "${WORKDIR}/${EXALT_MODULE}"
-
-inherit autotools pkgconfig
-
-EXALT_MODULE ?= "${PN}"
diff --git a/recipes/exalt/exalt_svn.bb b/recipes/exalt/exalt_svn.bb
deleted file mode 100644
index 0ed46a2e96..0000000000
--- a/recipes/exalt/exalt_svn.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore etk edbus libexalt libexalt-dbus"
-RDEPENDS_${PN} = "exalt-daemon"
diff --git a/recipes/exalt/libexalt-dbus_svn.bb b/recipes/exalt/libexalt-dbus_svn.bb
deleted file mode 100644
index e40766bfe5..0000000000
--- a/recipes/exalt/libexalt-dbus_svn.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore edbus libexalt"
-
-do_stage() {
- autotools_stage_all
-}
-
-EXALT_MODULE = "libexalt_dbus"
diff --git a/recipes/exalt/libexalt_svn.bb b/recipes/exalt/libexalt_svn.bb
deleted file mode 100644
index cd70d52c77..0000000000
--- a/recipes/exalt/libexalt_svn.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require exalt.inc
-
-DEPENDS = "ecore eet ecore edbus evas wpa-supplicant dhcp"
-RDEPENDS_${PN} = "wpa-supplicant dhclient"
-
-do_stage() {
- autotools_stage_all
-}