aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/expat/expat_1.95.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/expat/expat_1.95.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/expat/expat_1.95.7.bb')
-rw-r--r--recipes/expat/expat_1.95.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/expat/expat_1.95.7.bb b/recipes/expat/expat_1.95.7.bb
new file mode 100644
index 0000000000..7b48305933
--- /dev/null
+++ b/recipes/expat/expat_1.95.7.bb
@@ -0,0 +1,26 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1 \
+ file://expat-XMLCALL.patch;patch=1 \
+ "
+
+inherit lib_package
+
+do_configure () {
+ rm -f ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}