aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb')
-rw-r--r--recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb b/recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb
new file mode 100644
index 0000000000..fbf5f61a39
--- /dev/null
+++ b/recipes/ez-ipupdate/ez-ipupdate_3.0.10.bb
@@ -0,0 +1,31 @@
+# Angus Mackay's ez-ipupdate from www.ez-ipupdate.com
+DESCRIPTION = "A client for automatically updating your EZ-IP.net, justlinux.com, dhs.org, dyndns.org, ods.org, gnudip.cheapnet.net, tzo.com, easydns.com dynamic hostname parameters. Includes daemon support that only sends updates if your IP address changes."
+HOMEPAGE = "http://www.ez-ipupdate.com/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.ez-ipupdate.com/dist/ez-ipupdate-${PV}.tar.gz"
+SRC_URI += "file://configure.patch;patch=1"
+SRC_URI += "file://conffile.patch;patch=1"
+SRC_URI += "file://zoneedit.patch;patch=1"
+SRC_URI += "file://init"
+SRC_URI += "file://ipupdate.conf"
+
+INITSCRIPT_NAME = "ipupdate"
+# No dependencies, so just go in at the standard level (20)
+INITSCRIPT_PARAMS = "defaults"
+
+# The configuration file must be editted...
+CONFFILES_${PN} = "${sysconfdir}/ipupdate.conf"
+
+inherit autotools update-rc.d
+
+PACKAGES += "ez-ipupdate"
+
+do_install_append() {
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init "${D}${sysconfdir}/init.d/ipupdate"
+ install -c -m 644 ${WORKDIR}/ipupdate.conf "${D}${sysconfdir}/ipupdate.conf"
+}