aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ezx
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ezx')
-rw-r--r--recipes/ezx/ezx-boot-usb-native_svn.bb28
-rw-r--r--recipes/ezx/ezx-gen-blob_svn.bb39
-rw-r--r--recipes/ezx/ezx-gpiotool_1877.bb26
-rw-r--r--recipes/ezx/ezxd/ezxd.init78
-rw-r--r--recipes/ezx/ezxd_svn.bb43
-rw-r--r--recipes/ezx/files/remove-bogus-sed.patch15
6 files changed, 229 insertions, 0 deletions
diff --git a/recipes/ezx/ezx-boot-usb-native_svn.bb b/recipes/ezx/ezx-boot-usb-native_svn.bb
new file mode 100644
index 0000000000..426ad4a555
--- /dev/null
+++ b/recipes/ezx/ezx-boot-usb-native_svn.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.3.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
+
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile
diff --git a/recipes/ezx/ezx-gen-blob_svn.bb b/recipes/ezx/ezx-gen-blob_svn.bb
new file mode 100644
index 0000000000..5841407ce3
--- /dev/null
+++ b/recipes/ezx/ezx-gen-blob_svn.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Generic Blob [Bootloader] for the Motorola EZX platform"
+SECTION = "bootloaders"
+AUTHOR = "OpenEZX Team"
+HOMEPAGE = "http://people.openezx.org/wyrm/gen-blob"
+LICENSE = "GPL"
+PROVIDES = "virtual/bootloader"
+DEPENDS = "virtual/kernel"
+PV = "1.0.0+${SRCREV}"
+PR = "r1"
+
+SRC_URI = "\
+ svn://svn.openezx.org/trunk/src/blob/;module=gen-blob;proto=http \
+ file://remove-bogus-sed.patch;patch=1 \
+"
+S = "${WORKDIR}/gen-blob"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-board=lubbock \
+ --with-cpu=pxa262 \
+ --with-linux-prefix=${STAGING_KERNEL_DIR} \
+ --enable-usb \
+"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 src/blob/blob-a780 ${DEPLOY_DIR_IMAGE}/gen-blob-for-1stgen.${SRCDATE}
+ install -m 0644 src/blob/blob-a1200 ${DEPLOY_DIR_IMAGE}/gen-blob-for-2ndgen.${SRCDATE}
+}
+
+addtask deploy before do_build after do_compile
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/ezx/ezx-gpiotool_1877.bb b/recipes/ezx/ezx-gpiotool_1877.bb
new file mode 100644
index 0000000000..81a1ecc2a0
--- /dev/null
+++ b/recipes/ezx/ezx-gpiotool_1877.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gpiotool can read/write gpio configuration from userspace."
+SECTION = "devel"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.openezx.org"
+AUTHOR = "Harald Welte"
+PR = "r0"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=gpiotool;proto=http;rev=${PV}"
+S = "${WORKDIR}/gpiotool"
+
+do_compile() {
+ for i in mmio.c gpiotool.c gpio.c
+ do
+ ${CC} ${CFLAGS} -c $i
+ done
+ ${CC} ${CFLAGS} -o ezx-gpiotool mmio.o gpiotool.o gpio.o
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ezx-gpiotool ${D}${sbindir}
+}
diff --git a/recipes/ezx/ezxd/ezxd.init b/recipes/ezx/ezxd/ezxd.init
new file mode 100644
index 0000000000..a345952d1e
--- /dev/null
+++ b/recipes/ezx/ezxd/ezxd.init
@@ -0,0 +1,78 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# init.d script for ezxd
+
+set -e
+
+DAEMON=/usr/bin/ezxd
+NAME=ezxd
+PIDDIR=/var/run/ezxd
+PIDFILE=$PIDDIR/pid
+DESC="ezxd server"
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/ezxd ]; then
+ . /etc/default/ezxd
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
+ --exec $DAEMON -- --system $PARAMS
+ # We need to sleep here because opening the mux devices takes some time
+ sleep 15
+ echo "$NAME."
+}
+
+shut_it_down()
+{
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE
+
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ restart|force-reload)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/ezx/ezxd_svn.bb b/recipes/ezx/ezxd_svn.bb
new file mode 100644
index 0000000000..ab1010c48e
--- /dev/null
+++ b/recipes/ezx/ezxd_svn.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Open implementation of motorola's tapisrv, replaces opentapi"
+LICENSE = "GPLv2"
+SECTION = "devel"
+AUTHOR = "Daniel Ribeiro"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=ezxd;proto=http \
+ file://ezxd.init \
+ "
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ezxd"
+INITSCRIPT_PARAMS = "start 00 S ."
+
+S = "${WORKDIR}/${PN}"
+
+CFLAGS_append = " -DDEBUG "
+
+do_configure() {
+ sed -i -e s:CROSS:CC:g Makefile
+}
+
+fakeroot do_install() {
+ install -d ${D}/dev/input
+ mknod ${D}/dev/input/uinput c 10 223
+
+ install -d ${D}${bindir}
+ install -m 755 ezxd ${D}${bindir}
+
+ install -d ${D}${libdir}/ezxd
+ install -m 755 *.so ${D}${libdir}/ezxd
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0600 ezxd.conf ${D}${sysconfdir}/
+ install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
+}
+
+FILES_${PN} += "/dev"
+CONFFILES_${PN} += "${sysconfdir}/ezxd.conf"
+
diff --git a/recipes/ezx/files/remove-bogus-sed.patch b/recipes/ezx/files/remove-bogus-sed.patch
new file mode 100644
index 0000000000..8597ed945d
--- /dev/null
+++ b/recipes/ezx/files/remove-bogus-sed.patch
@@ -0,0 +1,15 @@
+Index: gen-blob/configure
+===================================================================
+--- gen-blob.orig/configure
++++ gen-blob/configure
+@@ -1970,8 +1970,8 @@
+ fi
+
+
+-CFLAGS=`echo $CFLAGS | sed 's/\ *-g\ */\ /'`
+-LDFLAGS=`echo $LDFLAGS | sed 's/\ *-g\ */\ /'`
++CFLAGS=`echo $CFLAGS`
++LDFLAGS=`echo $LDFLAGS`
+ CCAS=`echo $CC`
+ CCASFLAGS=`echo $CFLAGS -D__ASSEMBLY__ `
+