summaryrefslogtreecommitdiffstats
path: root/recipes/ezx
diff options
context:
space:
mode:
authorAntonio Ospite <ospite@studenti.unina.it>2010-06-16 16:27:24 +0200
committerAntonio Ospite <ospite@studenti.unina.it>2010-06-20 18:45:54 +0200
commitd8fd4a34d047fc16589fa99364a82a9f52c8dc3a (patch)
tree35864a0a5c08cdd264c8eac82b7cb398e98f9bc1 /recipes/ezx
parent7451853acecd4a26860afc0dbaeafbf6e32170ae (diff)
downloadopenembedded-d8fd4a34d047fc16589fa99364a82a9f52c8dc3a.tar.gz
ezx: rename ezx-boot-usb recipe to moto-boot-usb, use git
boot_usb is now named moto-boot-usb and is hosted on git.openezx.org, move recipes/ezx/ezx-boot-usb-native_svn.bb to recipes/ezx/moto-boot-usb-native_git.bb and fix it. Signed-off-by: Antonio Ospite <ospite@studenti.unina.it> Acked-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
Diffstat (limited to 'recipes/ezx')
-rw-r--r--recipes/ezx/moto-boot-usb-native_git.bb (renamed from recipes/ezx/ezx-boot-usb-native_svn.bb)18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes/ezx/ezx-boot-usb-native_svn.bb b/recipes/ezx/moto-boot-usb-native_git.bb
index 280de30e24..e6fdaa19cb 100644
--- a/recipes/ezx/ezx-boot-usb-native_svn.bb
+++ b/recipes/ezx/moto-boot-usb-native_git.bb
@@ -3,11 +3,13 @@ DEPENDS = "virtual/libusb0-native virtual/kernel"
SECTION = "devel"
AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
LICENSE = "GPL"
-SRCREV = "2522"
-PV = "0.3.0+svnr${SRCPV}"
+SRCREV = "d7136c6c9fe9d62b8f3defccef5dca47258bef63"
+PV = "0.3.0+gitr${SRCPV}"
+PR = "r0"
+PE = "1"
-SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
-S = "${WORKDIR}/boot_usb"
+SRC_URI = "git://git.openezx.org/moto-boot-usb.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
@@ -15,15 +17,11 @@ inherit autotools native
do_deploy() {
install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 src/boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
-}
-
-do_stage() {
- :
+ install -m 0755 src/moto-boot-usb ${DEPLOY_DIR_TOOLS}/moto-boot-usb-${PV}
}
do_install() {
- :
+ :
}
addtask deploy before do_build after do_compile