aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/faad2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/faad2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/faad2')
-rw-r--r--recipes/faad2/faad2-2.0/Makefile.am3
-rw-r--r--recipes/faad2/faad2-2.0/faad2-gcc-fix.patch11
-rw-r--r--recipes/faad2/faad2_2.0.bb36
3 files changed, 50 insertions, 0 deletions
diff --git a/recipes/faad2/faad2-2.0/Makefile.am b/recipes/faad2/faad2-2.0/Makefile.am
new file mode 100644
index 0000000000..dc4f7d9c30
--- /dev/null
+++ b/recipes/faad2/faad2-2.0/Makefile.am
@@ -0,0 +1,3 @@
+SUBDIRS = libfaad common frontend plugins
+
+
diff --git a/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch b/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch
new file mode 100644
index 0000000000..943b89a53f
--- /dev/null
+++ b/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/mp4ff.c 2006-11-11 21:25:07.000000000 +0100
++++ faad2/common/mp4ff/mp4ff.c 2006-11-11 21:25:20.348554000 +0100
+@@ -87,7 +87,7 @@
+ if (ff) free(ff);
+ }
+
+-static void mp4ff_track_add(mp4ff_t *f)
++void mp4ff_track_add(mp4ff_t *f)
+ {
+ f->total_tracks++;
+
diff --git a/recipes/faad2/faad2_2.0.bb b/recipes/faad2/faad2_2.0.bb
new file mode 100644
index 0000000000..90255b3fd8
--- /dev/null
+++ b/recipes/faad2/faad2_2.0.bb
@@ -0,0 +1,36 @@
+
+DESCRIPTION = "Library for reading some sort of media format."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+DEPENDS = ""
+PR ="r2"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/faac/${PN}-${PV}.zip \
+ file://faad2-gcc-fix.patch;patch=1 \
+ file://Makefile.am"
+
+S="${WORKDIR}/${PN}"
+
+do_configure_prepend() {
+ mv ${WORKDIR}/Makefile.am ${S}/
+}
+
+PACKAGES =+ "libfaad libfaad-dev libmp4ff libmp4ff-dev"
+
+FILES_${PN} = "${bindir}/faad"
+
+FILES_libfaad = "${libdir}/libfaad.so.0 ${libdir}/libfaad.so.0.0.0"
+FILES_libfaad-dev = "${libdir}/libfaad.so ${libdir}/libfaad.la ${libdir}/libfaad.a ${includedir}/faad.h"
+
+FILES_libmp4ff = "${libdir}/libmp4ff.so.0 ${libdir}/libmp4ff.so.0.0.0"
+FILES_libmp4ff-dev = "${libdir}/libmp4ff.so ${libdir}/libmp4ff.la ${libdir}/libmp4ff.a ${includedir}/mp4ff.h"
+
+do_stage() {
+ oe_libinstall -a -so -C libfaad libfaad ${STAGING_LIBDIR}
+ install -m 0644 ${S}/include/faad.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so -C common/mp4ff libmp4ff ${STAGING_LIBDIR}
+ install -m 0644 ${S}/common/mp4ff/mp4ff.h ${STAGING_INCDIR}/
+}