aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-06-17 12:02:13 +0200
committerKoen Kooi <koen@openembedded.org>2010-06-17 12:07:02 +0200
commit69d4f160583e764448f359d2aced62345be3e387 (patch)
tree33b349bed74e1dc1f6ee1b0c85c41a3476b745b8 /recipes/fakeroot
parent689618f8e29104fa85bc979efc51659b7b147ca8 (diff)
downloadopenembedded-69d4f160583e764448f359d2aced62345be3e387.tar.gz
fakeroot(-native): convert to new style staging
Staging looks really weird, but it matches the way it was.
Diffstat (limited to 'recipes/fakeroot')
-rw-r--r--recipes/fakeroot/fakeroot-native_1.12.4.bb4
-rw-r--r--recipes/fakeroot/fakeroot_1.12.4.bb11
2 files changed, 7 insertions, 8 deletions
diff --git a/recipes/fakeroot/fakeroot-native_1.12.4.bb b/recipes/fakeroot/fakeroot-native_1.12.4.bb
index 2279094224..e6add2bb26 100644
--- a/recipes/fakeroot/fakeroot-native_1.12.4.bb
+++ b/recipes/fakeroot/fakeroot-native_1.12.4.bb
@@ -13,9 +13,7 @@ python () {
bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
}
-do_stage_append () {
- oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
+NATIVE_INSTALL_WORKS = "1"
RDEPENDS_${PN} = "util-linux-native"
diff --git a/recipes/fakeroot/fakeroot_1.12.4.bb b/recipes/fakeroot/fakeroot_1.12.4.bb
index 19a493cc2c..c265749f64 100644
--- a/recipes/fakeroot/fakeroot_1.12.4.bb
+++ b/recipes/fakeroot/fakeroot_1.12.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Gives a fake root environment"
HOMEPAGE = "http://fakeroot.alioth.debian.org"
SECTION = "base"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "\
${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
@@ -11,10 +11,11 @@ SRC_URI = "\
inherit autotools
-do_stage() {
- install -d ${STAGING_INCDIR}/fakeroot
- install -m 644 *.h ${STAGING_INCDIR}/fakeroot
- autotools_stage_all
+do_install_append() {
+ install -d ${D}${includedir}/fakeroot
+ install -m 644 *.h ${D}${includedir}/fakeroot
+ install -d ${D}${libdir}/libfakeroot/
+ oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
}
# fakeroot needs getopt which is provided by the util-linux package