aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fakeroot
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fakeroot')
-rw-r--r--recipes/fakeroot/fakeroot-1.9.6/configure-libtool.patch18
-rw-r--r--recipes/fakeroot/fakeroot-1.9.6/fix-prefix.patch18
-rw-r--r--recipes/fakeroot/fakeroot-native_1.12.1.bb20
-rw-r--r--recipes/fakeroot/fakeroot-native_1.9.6.bb21
-rw-r--r--recipes/fakeroot/fakeroot_1.12.1.bb21
-rw-r--r--recipes/fakeroot/fakeroot_1.9.6.bb18
-rw-r--r--recipes/fakeroot/files/configure-libtool.patch20
-rw-r--r--recipes/fakeroot/files/fix-prefix.patch15
8 files changed, 151 insertions, 0 deletions
diff --git a/recipes/fakeroot/fakeroot-1.9.6/configure-libtool.patch b/recipes/fakeroot/fakeroot-1.9.6/configure-libtool.patch
new file mode 100644
index 0000000000..8830328eb5
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.9.6/configure-libtool.patch
@@ -0,0 +1,18 @@
+--- fakeroot-1.8.3/configure.ac.orig 2007-10-31 00:17:27.000000000 -0500
++++ fakeroot-1.8.3/configure.ac 2007-10-31 00:18:12.000000000 -0500
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AC_ARG_WITH([ipc],
+ AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
diff --git a/recipes/fakeroot/fakeroot-1.9.6/fix-prefix.patch b/recipes/fakeroot/fakeroot-1.9.6/fix-prefix.patch
new file mode 100644
index 0000000000..3884aca01c
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.9.6/fix-prefix.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
++++ fakeroot-1.2.13/scripts/fakeroot.in
+@@ -15,8 +15,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ LIB=lib@fakeroot_transformed@.so.0
+ PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot
diff --git a/recipes/fakeroot/fakeroot-native_1.12.1.bb b/recipes/fakeroot/fakeroot-native_1.12.1.bb
new file mode 100644
index 0000000000..5215dc86ed
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-native_1.12.1.bb
@@ -0,0 +1,20 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
+RDEPENDS = "util-linux-native"
diff --git a/recipes/fakeroot/fakeroot-native_1.9.6.bb b/recipes/fakeroot/fakeroot-native_1.9.6.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-native_1.9.6.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/recipes/fakeroot/fakeroot_1.12.1.bb b/recipes/fakeroot/fakeroot_1.12.1.bb
new file mode 100644
index 0000000000..4b61f252fb
--- /dev/null
+++ b/recipes/fakeroot/fakeroot_1.12.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1 \
+"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+
diff --git a/recipes/fakeroot/fakeroot_1.9.6.bb b/recipes/fakeroot/fakeroot_1.9.6.bb
new file mode 100644
index 0000000000..aaf696d79d
--- /dev/null
+++ b/recipes/fakeroot/fakeroot_1.9.6.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}
diff --git a/recipes/fakeroot/files/configure-libtool.patch b/recipes/fakeroot/files/configure-libtool.patch
new file mode 100644
index 0000000000..46f7df7025
--- /dev/null
+++ b/recipes/fakeroot/files/configure-libtool.patch
@@ -0,0 +1,20 @@
+Index: fakeroot-1.12.1/configure.ac
+===================================================================
+--- fakeroot-1.12.1.orig/configure.ac
++++ fakeroot-1.12.1/configure.ac
+@@ -2,14 +2,12 @@
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+ AC_CONFIG_MACRO_DIR([build-aux])
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AH_BOTTOM([#if ! HAVE_BUILTIN_EXPECT
+ #define __builtin_expect(x, expected_value) (x)
diff --git a/recipes/fakeroot/files/fix-prefix.patch b/recipes/fakeroot/files/fix-prefix.patch
new file mode 100644
index 0000000000..3c47bd7650
--- /dev/null
+++ b/recipes/fakeroot/files/fix-prefix.patch
@@ -0,0 +1,15 @@
+Index: fakeroot-1.12.1/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.12.1.orig/scripts/fakeroot.in
++++ fakeroot-1.12.1/scripts/fakeroot.in
+@@ -30,8 +30,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@