aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fam
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fam
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fam')
-rw-r--r--recipes/fam/fam-2.6.10/rpcsvc.patch17
-rw-r--r--recipes/fam/fam-2.7.0/compile-fix.patch27
-rw-r--r--recipes/fam/fam_2.6.10.bb17
-rw-r--r--recipes/fam/fam_2.7.0.bb17
4 files changed, 78 insertions, 0 deletions
diff --git a/recipes/fam/fam-2.6.10/rpcsvc.patch b/recipes/fam/fam-2.6.10/rpcsvc.patch
new file mode 100644
index 0000000000..ce36beb634
--- /dev/null
+++ b/recipes/fam/fam-2.6.10/rpcsvc.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.6.10/fam/Makefile.am~rpcsvc 2003-04-15 00:21:26.000000000 -0400
++++ fam-2.6.10/fam/Makefile.am 2004-03-05 10:43:32.000000000 -0500
+@@ -76,7 +76,8 @@
+
+ EXTRA_fam_SOURCES = IMonIrix.c++ IMonLinux.c++ IMonNone.c++
+
+-fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++#fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++fam_LDADD = $(top_srcdir)/support/libsupport.a
+
+ CLEANFILES += @MKDEPFILE@ ii_files/*.ii
+ sinclude @MKDEPFILE@
diff --git a/recipes/fam/fam-2.7.0/compile-fix.patch b/recipes/fam/fam-2.7.0/compile-fix.patch
new file mode 100644
index 0000000000..cb9c702af5
--- /dev/null
+++ b/recipes/fam/fam-2.7.0/compile-fix.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.7.0/src/Listener.c++~compile-fix 2003-01-20 01:37:29.000000000 +0100
++++ fam-2.7.0/src/Listener.c++ 2004-02-28 23:53:57.000000000 +0100
+@@ -45,7 +45,7 @@
+ #include "BTree.h"
+
+ #if !(HAVE_BINDRESVPORT_PROTO)
+-extern "C" int bindresvport(int sd, struct sockaddr_in *);
++extern "C" int bindresvport(int sd, struct sockaddr_in *) throw();
+ #endif
+
+ struct NegotiatingClient
+--- fam-2.7.0/src/Log.c++~compile-fix 2003-01-18 15:18:12.000000000 +0100
++++ fam-2.7.0/src/Log.c++ 2004-02-29 02:23:23.000000000 +0100
+@@ -264,7 +264,7 @@
+ // New back end for assert() will log to syslog, put core file
+ // in known directory.
+
+-void __assert(const char *msg, const char *file, int line)
++void __assert(const char *msg, const char *file, int line) throw()
+ {
+ char *dirname = new char[strlen(Log::getName()) + 20];
+ (void) sprintf(dirname, "/usr/tmp/%s.%d", Log::getName(), getpid());
diff --git a/recipes/fam/fam_2.6.10.bb b/recipes/fam/fam_2.6.10.bb
new file mode 100644
index 0000000000..870c67719f
--- /dev/null
+++ b/recipes/fam/fam_2.6.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://rpcsvc.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C libfam libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+
diff --git a/recipes/fam/fam_2.7.0.bb b/recipes/fam/fam_2.7.0.bb
new file mode 100644
index 0000000000..653aea6d3c
--- /dev/null
+++ b/recipes/fam/fam_2.7.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C lib libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+