summaryrefslogtreecommitdiffstats
path: root/recipes/farsight
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
commit1f9093d95cb44179d171d337b63f2c5ecaf94086 (patch)
tree0b8b8349b5304e565cc28d69e23623333316f85a /recipes/farsight
parent28bac40e6c1bde11de63deda391624ed6dfff3f1 (diff)
downloadopenembedded-1f9093d95cb44179d171d337b63f2c5ecaf94086.tar.gz
telepathy: update empathy and telepathy bits
Diffstat (limited to 'recipes/farsight')
-rw-r--r--recipes/farsight/farsight2_0.0.9.bb22
-rw-r--r--recipes/farsight/libnice_0.0.6.bb23
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/farsight/farsight2_0.0.9.bb b/recipes/farsight/farsight2_0.0.9.bb
new file mode 100644
index 0000000000..19e081c33a
--- /dev/null
+++ b/recipes/farsight/farsight2_0.0.9.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE = "http://farsight.sf.net"
+SRC_URI = "http://farsight.freedesktop.org/releases/farsight2/${P}.tar.gz"
+
+DEPENDS = "libnice glib-2.0 libxml2 zlib dbus gstreamer gst-plugins-base"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = " \
+ --disable-debug \
+ --disable-gtk-doc \
+ --disable-python \
+"
+
+FILES_${PN} += "${libdir}/*/*.so"
+FILES_${PN}-dev += "${libdir}/*/*a"
+FILES_${PN}-dbg += "${libdir}/*/.debug"
+
+
+
+
diff --git a/recipes/farsight/libnice_0.0.6.bb b/recipes/farsight/libnice_0.0.6.bb
new file mode 100644
index 0000000000..fa478dc0e3
--- /dev/null
+++ b/recipes/farsight/libnice_0.0.6.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)."
+HOMEPAGE = "http://nice.freedesktop.org/wiki/"
+SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
+
+LICENSE = "LGPL/MPL"
+DEPENDS = "glib-2.0 gstreamer"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*a"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+
+do_compile_append() {
+ for i in $(find ${S} -name "*.pc") ; do
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ $i
+ done
+}
+
+