aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fastjar
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-10-29 05:18:07 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-02 14:38:19 +0100
commit00993186da6ba1da98aa52464288b15462381290 (patch)
tree6639c0b6e209d6bd3a751a541551485cd32a3ac0 /recipes/fastjar
parent549bda4de616c0f29665735912f350de694fcdd5 (diff)
downloadopenembedded-00993186da6ba1da98aa52464288b15462381290.tar.gz
fastjar 0.98: add non-native recipe
Signed-off-by: Michael Smith <msmith@cbnco.com> Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes/fastjar')
-rw-r--r--recipes/fastjar/fastjar-native.inc12
-rw-r--r--recipes/fastjar/fastjar-native_0.95.bb1
-rw-r--r--recipes/fastjar/fastjar-native_0.98.bb1
-rw-r--r--recipes/fastjar/fastjar.inc16
-rw-r--r--recipes/fastjar/fastjar_0.98.bb1
5 files changed, 20 insertions, 11 deletions
diff --git a/recipes/fastjar/fastjar-native.inc b/recipes/fastjar/fastjar-native.inc
index df4d260713..e4d7084138 100644
--- a/recipes/fastjar/fastjar-native.inc
+++ b/recipes/fastjar/fastjar-native.inc
@@ -1,18 +1,8 @@
-DESCRIPTION = "jar replacement written in C."
-HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-INC_PR = "r2"
-
DEPENDS = "zlib-native"
-SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
-
S = "${WORKDIR}/fastjar-${PV}"
-inherit autotools native
+inherit native
do_configure () {
gnu-configize || die "failure running gnu-configize"
diff --git a/recipes/fastjar/fastjar-native_0.95.bb b/recipes/fastjar/fastjar-native_0.95.bb
index 6d2cdb4f24..342bf7ccfc 100644
--- a/recipes/fastjar/fastjar-native_0.95.bb
+++ b/recipes/fastjar/fastjar-native_0.95.bb
@@ -1,3 +1,4 @@
+require fastjar.inc
require fastjar-native.inc
PR = "${INC_PR}.1"
diff --git a/recipes/fastjar/fastjar-native_0.98.bb b/recipes/fastjar/fastjar-native_0.98.bb
index 6d2cdb4f24..342bf7ccfc 100644
--- a/recipes/fastjar/fastjar-native_0.98.bb
+++ b/recipes/fastjar/fastjar-native_0.98.bb
@@ -1,3 +1,4 @@
+require fastjar.inc
require fastjar-native.inc
PR = "${INC_PR}.1"
diff --git a/recipes/fastjar/fastjar.inc b/recipes/fastjar/fastjar.inc
new file mode 100644
index 0000000000..7c5439edb4
--- /dev/null
+++ b/recipes/fastjar/fastjar.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "zlib"
+
+INC_PR = "r3"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES =+ "${PN}-grepjar"
+FILES_${PN}-grepjar = "${bindir}/grepjar"
diff --git a/recipes/fastjar/fastjar_0.98.bb b/recipes/fastjar/fastjar_0.98.bb
new file mode 100644
index 0000000000..35392f23ee
--- /dev/null
+++ b/recipes/fastjar/fastjar_0.98.bb
@@ -0,0 +1 @@
+require fastjar.inc