aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fastjar
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fastjar
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fastjar')
-rw-r--r--recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb31
-rw-r--r--recipes/fastjar/fastjar-native_0.95.bb29
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb b/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
new file mode 100644
index 0000000000..367912fa8b
--- /dev/null
+++ b/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "zlib"
+
+GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
+
+S = "${WORKDIR}/gcc-${GCC_VER}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake maybe-all-fastjar
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
+ install -m 755 fastjar/grepjar ${STAGING_BINDIR}
+}
diff --git a/recipes/fastjar/fastjar-native_0.95.bb b/recipes/fastjar/fastjar-native_0.95.bb
new file mode 100644
index 0000000000..3d003306b8
--- /dev/null
+++ b/recipes/fastjar/fastjar-native_0.95.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+DEPENDS = "zlib-native"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
+
+S = "${WORKDIR}/fastjar-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_stage() {
+ #we should teach autotools.bbclass:autotools_stage_all() about ${STAGING_BINDIR}
+ install -d ${STAGING_BINDIR}
+ install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
+ install -m 755 .libs/grepjar ${STAGING_BINDIR}
+}