summaryrefslogtreecommitdiffstats
path: root/recipes/fastjar
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-05-15 12:55:01 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-05-15 12:58:54 +0200
commit0f801ce2b17a92413a5af12d8534a088461c799e (patch)
tree0b61dc982dade6ea3c1d4eb5168462f5bd8a1e82 /recipes/fastjar
parent4154c5f1b9e65b5e2ecb026a06d53fe178921d26 (diff)
downloadopenembedded-0f801ce2b17a92413a5af12d8534a088461c799e.tar.gz
fastjar: switch to BBCLASSEXTEND and clean up
* remove older versions * we don't need the empty dev package, because there are no libs * bump INC_PR to get native and normal package to the same revision
Diffstat (limited to 'recipes/fastjar')
-rw-r--r--recipes/fastjar/fastjar-native.inc18
-rw-r--r--recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb34
-rw-r--r--recipes/fastjar/fastjar-native_0.95.bb7
-rw-r--r--recipes/fastjar/fastjar-native_0.98.bb7
-rw-r--r--recipes/fastjar/fastjar.inc8
-rw-r--r--recipes/fastjar/fastjar_0.98.bb2
6 files changed, 7 insertions, 69 deletions
diff --git a/recipes/fastjar/fastjar-native.inc b/recipes/fastjar/fastjar-native.inc
deleted file mode 100644
index e4d7084138..0000000000
--- a/recipes/fastjar/fastjar-native.inc
+++ /dev/null
@@ -1,18 +0,0 @@
-DEPENDS = "zlib-native"
-
-S = "${WORKDIR}/fastjar-${PV}"
-
-inherit native
-
-do_configure () {
- gnu-configize || die "failure running gnu-configize"
- oe_runconf
-}
-
-do_make() {
- oe_runmake bin_PROGRAMS
-}
-
-do_stage() {
- oe_runmake install-binPROGRAMS
-}
diff --git a/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb b/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
deleted file mode 100644
index 7da694873e..0000000000
--- a/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "jar replacement written in C."
-HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-DEPENDS = "zlib"
-
-GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
-SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
-
-S = "${WORKDIR}/gcc-${GCC_VER}"
-
-inherit autotools native
-
-EXTRA_OECONF = "--with-system-zlib --with-fastjar"
-
-do_configure () {
- gnu-configize || die "failure running gnu-configize"
- oe_runconf
-}
-
-do_compile() {
- oe_runmake maybe-all-fastjar
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
- install -m 755 fastjar/grepjar ${STAGING_BINDIR}
-}
-
-SRC_URI[md5sum] = "2fada3a3effd2fd791df09df1f1534b3"
-SRC_URI[sha256sum] = "522c53b92ff9096089f3074c50e17a5169952d32f4c883c6fdae350e8f1b344e"
diff --git a/recipes/fastjar/fastjar-native_0.95.bb b/recipes/fastjar/fastjar-native_0.95.bb
deleted file mode 100644
index 5ca9b5fc9b..0000000000
--- a/recipes/fastjar/fastjar-native_0.95.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require fastjar.inc
-require fastjar-native.inc
-
-PR = "${INC_PR}.1"
-
-SRC_URI[md5sum] = "92a70f9e56223b653bce0f58f90cf950"
-SRC_URI[sha256sum] = "ca03811490c965abc9f466e75418ae48bb71f14d8e8ed4c43e8109207b85ce54"
diff --git a/recipes/fastjar/fastjar-native_0.98.bb b/recipes/fastjar/fastjar-native_0.98.bb
deleted file mode 100644
index 11f76f41c7..0000000000
--- a/recipes/fastjar/fastjar-native_0.98.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require fastjar.inc
-require fastjar-native.inc
-
-PR = "${INC_PR}.1"
-
-SRC_URI[md5sum] = "d2d264d343d4d0e1575832cc1023c3bf"
-SRC_URI[sha256sum] = "f156abc5de8658f22ee8f08d7a72c88f9409ebd8c7933e9466b0842afeb2f145"
diff --git a/recipes/fastjar/fastjar.inc b/recipes/fastjar/fastjar.inc
index 7c5439edb4..5f6285a1f2 100644
--- a/recipes/fastjar/fastjar.inc
+++ b/recipes/fastjar/fastjar.inc
@@ -2,15 +2,17 @@ DESCRIPTION = "jar replacement written in C."
HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
SECTION = "devel"
PRIORITY = "optional"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
DEPENDS = "zlib"
-INC_PR = "r3"
+INC_PR = "r4"
+
+BBCLASSEXTEND = "native"
SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
inherit autotools
-PACKAGES =+ "${PN}-grepjar"
+PACKAGES = "${PN}-grepjar ${PN} ${PN}-dbg ${PN}-doc"
FILES_${PN}-grepjar = "${bindir}/grepjar"
diff --git a/recipes/fastjar/fastjar_0.98.bb b/recipes/fastjar/fastjar_0.98.bb
index 652e8e71dc..e9be4e14a9 100644
--- a/recipes/fastjar/fastjar_0.98.bb
+++ b/recipes/fastjar/fastjar_0.98.bb
@@ -1,4 +1,6 @@
require fastjar.inc
+PR = "${INC_PR}.1"
+
SRC_URI[md5sum] = "d2d264d343d4d0e1575832cc1023c3bf"
SRC_URI[sha256sum] = "f156abc5de8658f22ee8f08d7a72c88f9409ebd8c7933e9466b0842afeb2f145"