summaryrefslogtreecommitdiffstats
path: root/recipes/fastjar
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-10-02 12:36:39 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-10-02 12:37:54 +0200
commit6856ab2772f19a4c6e0fbe63b7f176dac27c5b20 (patch)
treee344c5185a2ee3b7d29dfc3931de60c9ec0f6ab4 /recipes/fastjar
parent664d9450011eb82b7e6e6f7dfaca3b0cddd88786 (diff)
downloadopenembedded-6856ab2772f19a4c6e0fbe63b7f176dac27c5b20.tar.gz
fastjar: update to 0.98
* switch to INC_PR and .inc
Diffstat (limited to 'recipes/fastjar')
-rw-r--r--recipes/fastjar/fastjar-native.inc28
-rw-r--r--recipes/fastjar/fastjar-native_0.95.bb30
-rw-r--r--recipes/fastjar/fastjar-native_0.98.bb3
3 files changed, 33 insertions, 28 deletions
diff --git a/recipes/fastjar/fastjar-native.inc b/recipes/fastjar/fastjar-native.inc
new file mode 100644
index 0000000000..fa7c7ca646
--- /dev/null
+++ b/recipes/fastjar/fastjar-native.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+INC_PR = "r1"
+
+DEPENDS = "zlib-native"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
+
+S = "${WORKDIR}/fastjar-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
+ install -m 755 .libs/grepjar ${STAGING_BINDIR}
+}
diff --git a/recipes/fastjar/fastjar-native_0.95.bb b/recipes/fastjar/fastjar-native_0.95.bb
index 3d003306b8..6d2cdb4f24 100644
--- a/recipes/fastjar/fastjar-native_0.95.bb
+++ b/recipes/fastjar/fastjar-native_0.95.bb
@@ -1,29 +1,3 @@
-DESCRIPTION = "jar replacement written in C."
-HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "GPL"
+require fastjar-native.inc
-PR = "r1"
-
-DEPENDS = "zlib-native"
-
-SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
-
-S = "${WORKDIR}/fastjar-${PV}"
-
-inherit autotools native
-
-EXTRA_OECONF = "--with-system-zlib --with-fastjar"
-
-do_configure () {
- gnu-configize || die "failure running gnu-configize"
- oe_runconf
-}
-
-do_stage() {
- #we should teach autotools.bbclass:autotools_stage_all() about ${STAGING_BINDIR}
- install -d ${STAGING_BINDIR}
- install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
- install -m 755 .libs/grepjar ${STAGING_BINDIR}
-}
+PR = "${INC_PR}.1"
diff --git a/recipes/fastjar/fastjar-native_0.98.bb b/recipes/fastjar/fastjar-native_0.98.bb
new file mode 100644
index 0000000000..6d2cdb4f24
--- /dev/null
+++ b/recipes/fastjar/fastjar-native_0.98.bb
@@ -0,0 +1,3 @@
+require fastjar-native.inc
+
+PR = "${INC_PR}.1"