summaryrefslogtreecommitdiffstats
path: root/recipes/fbida/fbida_2.07.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fbida/fbida_2.07.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fbida/fbida_2.07.bb')
-rw-r--r--recipes/fbida/fbida_2.07.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/fbida/fbida_2.07.bb b/recipes/fbida/fbida_2.07.bb
new file mode 100644
index 0000000000..c3512e0fe7
--- /dev/null
+++ b/recipes/fbida/fbida_2.07.bb
@@ -0,0 +1,31 @@
+# - Currently this app needs ttf-dejavu-sans-mono[.ipk] installed!
+# - think about using fbi -a option for autozoom on tiny screens
+# - fbi displays in portrait-mode if your fb is in portrait (normal) mode too
+# (fbcon:rotate stands only for the fb console)
+
+HOMEPAGE = "http://linux.bytesex.org/fbida/"
+DESCRIPTION = "frame buffer image and doc viewer tools"
+AUTHOR = "Gerd Knorr"
+LICENSE = "GPL2"
+SECTION = "utils"
+PR = "r3"
+
+DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
+RDEPENDS = "ttf-dejavu-sans-mono"
+
+SRC_URI = "http://dl.bytesex.org/releases/fbida/fbida-${PV}.tar.gz \
+ file://exiftran.c.patch;patch=1 \
+ file://fbi.c.patch;patch=1 \
+ file://GNUmakefile.patch;patch=1 \
+ file://sys_siglist.patch;patch=1 \
+ "
+
+EXTRA_OEMAKE = ""
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}