aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv/fbv_1.0b.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-26 22:14:53 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-26 22:50:53 +0100
commitc9c44dd2fb216ff5185cb87f8424f3192f73b94b (patch)
tree54880b5efed8c85354a5b5e94e2de2b86c24c00f /recipes/fbv/fbv_1.0b.bb
parent106d2dcc40667f4370f936c16a52dccb14d9f759 (diff)
downloadopenembedded-c9c44dd2fb216ff5185cb87f8424f3192f73b94b.tar.gz
fbv: fix cflags and libs and enable libungif
* remove missleading patch * bump PR
Diffstat (limited to 'recipes/fbv/fbv_1.0b.bb')
-rw-r--r--recipes/fbv/fbv_1.0b.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
index 3629fe4d93..d8ca180642 100644
--- a/recipes/fbv/fbv_1.0b.bb
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -1,21 +1,23 @@
DESCRIPTION = "Frame Buffer Viewer"
LICENSE = "GPL"
-DEPENDS = "libpng jpeg"
-PR = "r3"
+DEPENDS = "libpng jpeg libungif"
+PR = "r4"
SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
file://cross_compile.patch \
- file://fbv-1.0b.patch \
file://fbv-1.0b-BGR666.patch \
+ file://libs.patch \
+ file://cflags.patch \
"
+CFLAGS += "-D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+
do_configure() {
- CC="${CC}" ./configure --without-libungif
+ CC="${CC}" ./configure
}
do_compile() {
- oe_runmake CC="${CC}" \
- CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+ oe_runmake CC="${CC}"
}
do_install() {