aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-23 15:07:52 -0400
committerTom Rini <trini@embeddedalley.com>2009-04-23 15:07:52 -0400
commit0bdb7654c8a9b9850db27e5f6b4a746fb1083ed1 (patch)
treecaccd525eaeb983b8f82fbb2f16818a9b821d715 /recipes/fbv
parentb0775dcad53b678235842eb18253b50c772d27a0 (diff)
downloadopenembedded-0bdb7654c8a9b9850db27e5f6b4a746fb1083ed1.tar.gz
fbv: Add a framebuffer-based png viewer.
bmp/gif is supported but disabled.
Diffstat (limited to 'recipes/fbv')
-rw-r--r--recipes/fbv/fbv-1.0b/cross_compile.patch41
-rw-r--r--recipes/fbv/fbv_1.0b.bb25
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes/fbv/fbv-1.0b/cross_compile.patch b/recipes/fbv/fbv-1.0b/cross_compile.patch
new file mode 100644
index 0000000000..df8be13b60
--- /dev/null
+++ b/recipes/fbv/fbv-1.0b/cross_compile.patch
@@ -0,0 +1,41 @@
+---
+ configure | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+Index: fbv-1.0b/configure
+===================================================================
+--- fbv-1.0b.orig/configure
++++ fbv-1.0b/configure
+@@ -106,12 +106,12 @@ xdir="/usr/X11R6"
+ ungif="no"
+ echo "libungif check" >>./config.log
+ echo " 1st:" >>./config.log
+-cc 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lungif $libs
++${CC} 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lungif $libs
+ if [ -e \$\$~test ]; then
+ libs="-lungif $libs" ; ungif="yes"
+ else
+ echo " 2nd: -lX11 -L$xdir/lib" >>./config.log
+- cc 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lungif -lX11 -L$xdir/lib $libs
++ ${CC} 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lungif -lX11 -L$xdir/lib $libs
+ if [ -e \$\$~test ]; then
+ libs="-lungif -lX11 -L$xdir/lib $libs" ; ungif="yes"
+ fi
+@@ -124,7 +124,7 @@ echo "libungif: $ungif" >> ./config.log
+ echo -n "checking for libjpeg presence... "
+ if [ "$jpeg" != "disabled" ]; then
+ jpeg="no"
+-cc 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -ljpeg $libs
++${CC} 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -ljpeg $libs
+ if [ -e \$\$~test ]; then
+ libs="-ljpeg $libs" ; jpeg="yes"
+ fi
+@@ -135,7 +135,7 @@ echo "libjpeg: $jpeg" >> ./config.log
+ echo -n "checking for libpng presence... "
+ if [ "$png" != "disabled" ]; then
+ png="no"
+-cc 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lpng $libs
++${CC} 2>>./config.log >>./config.log -o \$\$~test \$\$~test.c -lpng $libs
+ if [ -e \$\$~test ]; then
+ libs="-lpng $libs" ; png="yes"
+ fi
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
new file mode 100644
index 0000000000..04c70661d6
--- /dev/null
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Frame Buffer Viewer"
+LICENSE = "GPL"
+DEPENDS = "libpng"
+PR = "r1"
+
+SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
+ file://cross_compile.patch;patch=1"
+
+do_configure() {
+ CC="${CC}" ./configure --without-libungif --without-bmp \
+ --without-libjpeg
+}
+
+do_compile() {
+ oe_runmake CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES" \
+ CC="${CC}"
+}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fbv ${D}${bindir}
+
+ # man
+ install -d ${D}${mandir}/man1/
+ install -m 0644 fbv.1 ${D}${mandir}/man1/fbv.1
+}