aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2010-03-16 08:16:31 +0100
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2010-03-16 08:16:31 +0100
commit778845163c7978a4b912ca8f8be647f12f7a451e (patch)
tree784ca370fb6b06757fa1aa8adba562d3e57fb592 /recipes/fbv
parent9f06d76aaebf119e56973a0a2eecfa17689e3b0c (diff)
downloadopenembedded-778845163c7978a4b912ca8f8be647f12f7a451e.tar.gz
fbv-1.0: Build fbv with support for jpeg and bmp
fbv today only supports png files. This patch will enable jpeg and bmp support in fbv Signed-off-by: Ulf Samuelsson <ulf.samuelsson@atmel.com>
Diffstat (limited to 'recipes/fbv')
-rw-r--r--recipes/fbv/fbv-1.0b/fbv-1.0b.patch12
-rw-r--r--recipes/fbv/fbv_1.0b.bb25
2 files changed, 26 insertions, 11 deletions
diff --git a/recipes/fbv/fbv-1.0b/fbv-1.0b.patch b/recipes/fbv/fbv-1.0b/fbv-1.0b.patch
new file mode 100644
index 0000000000..2ca9d522b9
--- /dev/null
+++ b/recipes/fbv/fbv-1.0b/fbv-1.0b.patch
@@ -0,0 +1,12 @@
+diff -urN fbv-1.0b-0rig/Makefile fbv-1.0b/Makefile
+--- fbv-1.0b-0rig/Makefile 2009-08-20 00:33:58.000000000 +0200
++++ fbv-1.0b/Makefile 2009-08-20 00:34:16.000000000 +0200
+@@ -12,7 +12,7 @@
+ OBJECTS = ${SOURCES:.c=.o}
+
+ OUT = fbv
+-#LIBS = -lungif -L/usr/X11R6/lib -ljpeg -lpng
++LIBS = -L/usr/lib -ljpeg -lpng #-lungif
+
+ all: $(OUT)
+ @echo Build DONE.
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
index 04c70661d6..6016e0a709 100644
--- a/recipes/fbv/fbv_1.0b.bb
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -1,25 +1,28 @@
DESCRIPTION = "Frame Buffer Viewer"
LICENSE = "GPL"
-DEPENDS = "libpng"
-PR = "r1"
+DEPENDS = "libpng jpeg"
+PR = "r2"
SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
- file://cross_compile.patch;patch=1"
+ file://cross_compile.patch;patch=1 \
+ file://fbv-1.0b.patch;patch=1 \
+ "
do_configure() {
- CC="${CC}" ./configure --without-libungif --without-bmp \
- --without-libjpeg
+ CC="${CC}" ./configure --without-libungif
}
do_compile() {
- oe_runmake CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES" \
- CC="${CC}"
+ oe_runmake CC="${CC}" \
+ CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
}
+
do_install() {
install -d ${D}${bindir}
- install -m 0755 fbv ${D}${bindir}
+ install -m 0755 fbv ${D}${bindir}
- # man
- install -d ${D}${mandir}/man1/
- install -m 0644 fbv.1 ${D}${mandir}/man1/fbv.1
+# man
+ install -d ${D}${mandir}/man1/
+ install -m 0644 fbv.1 ${D}${mandir}/man1/fbv.1
}
+