aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg/ffmpeg_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-19 20:48:13 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-19 20:51:51 +0100
commitfb36a895a080c235bf797264cfcd04bffa820e1b (patch)
tree93f34e334542addcdeed9dc0b5aaa67f1ebc620d /recipes/ffmpeg/ffmpeg_git.bb
parent332cf7ffc4fc1e8ebbb28ba72bc59a4c89757387 (diff)
downloadopenembedded-fb36a895a080c235bf797264cfcd04bffa820e1b.tar.gz
ffmpeg svn: ffmpeg is in git now after the change of management, catch up with it
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ffmpeg/ffmpeg_git.bb')
-rw-r--r--recipes/ffmpeg/ffmpeg_git.bb36
1 files changed, 14 insertions, 22 deletions
diff --git a/recipes/ffmpeg/ffmpeg_git.bb b/recipes/ffmpeg/ffmpeg_git.bb
index 231b9cb76e..27e88ea7b2 100644
--- a/recipes/ffmpeg/ffmpeg_git.bb
+++ b/recipes/ffmpeg/ffmpeg_git.bb
@@ -1,26 +1,23 @@
require ffmpeg.inc
-DEPENDS += "schroedinger libgsm"
+DEPENDS += "virtual/libsdl schroedinger libgsm libvpx"
-PV = "0.5.0+${PR}+gitr${SRCPV}"
+# When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
+SRCREV = "a4f5af13fb00d7f55946470bb0f52e1dbf5f3c6a"
+
+PV = "0.6.1+${PR}+gitr${SRCPV}"
PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+DEFAULT_PREFERENCE_shr = "1"
-#FFBRANCH_arm = "arm"
-FFBRANCH ?= "master"
-
-# When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
-SRCREV = "d886804643d7427debfa70d824de7e53ae8e3e83"
-SRCREV_arm = "d886804643d7427debfa70d824de7e53ae8e3e83"
-SRCREV_libswscale = "b2e1c8222eeef74b0ca8053b400957dd69e18e4d"
-SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
-"
+SRC_URI = "git://git.ffmpeg.org/ffmpeg.git;protocol=git"
S = "${WORKDIR}/git"
B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
-FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
+FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fno-tree-vectorize -fomit-frame-pointer -O4 -ffast-math"
BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
@@ -31,22 +28,22 @@ EXTRA_OECONF = " \
--enable-pthreads \
--disable-stripping \
--enable-gpl \
- --enable-nonfree \
--enable-postproc \
\
--cross-prefix=${TARGET_PREFIX} \
--prefix=${prefix} \
\
+ --enable-ffserver \
+ --enable-ffplay \
--enable-x11grab \
- --enable-libfaac \
- --enable-libfaad \
- --enable-libfaadbin \
--enable-libgsm \
--enable-libmp3lame \
--enable-libschroedinger \
--enable-libtheora \
--enable-libvorbis \
+ --enable-libvpx \
--arch=${TARGET_ARCH} \
+ --target-os="linux" \
--enable-cross-compile \
--extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
--extra-ldflags="${TARGET_LDFLAGS}" \
@@ -55,12 +52,7 @@ EXTRA_OECONF = " \
"
do_configure() {
- sed -i -e s:'check_cflags -std=c99'::g ${S}/configure
- cd ${S}
- git clone git://git.mplayerhq.hu/libswscale || true
- cd libswscale
- git checkout ${SRCREV_libswscale} || true
- cd ${S}
+# sed -i -e s:'check_cflags -std=c99'::g ${S}/configure
mkdir -p ${B}
cd ${B}
${S}/configure ${EXTRA_OECONF}