aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-08 09:25:51 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-08 09:25:51 +0200
commitc01dca885928662046bd1eb67831452c786bbf11 (patch)
treeedaa1d626e2b951ea8134284ae46326a4f45d444 /recipes/ffmpeg
parentfde8767cb80d192b8fb51d843a645f60fcd357ac (diff)
downloadopenembedded-c01dca885928662046bd1eb67831452c786bbf11.tar.gz
omapfbplay: add xv version with netsync option
Diffstat (limited to 'recipes/ffmpeg')
-rw-r--r--recipes/ffmpeg/omapfbplay-xv_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/ffmpeg/omapfbplay-xv_git.bb b/recipes/ffmpeg/omapfbplay-xv_git.bb
new file mode 100644
index 0000000000..81501bb1a1
--- /dev/null
+++ b/recipes/ffmpeg/omapfbplay-xv_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
+DEPENDS = libxv "bzip2 lame ffmpeg virtual/kernel"
+LICENSE = "MIT"
+
+PV = "0.0+${PR}+gitr${SRCREV}"
+
+SRCREV = "e66bf25df1f1ff085e6db102b282d90e7ceff4bf"
+SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
+"
+
+S = "${WORKDIR}/git"
+
+# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
+STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
+
+CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include "
+
+do_compile() {
+ cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
+ oe_runmake XV=y NETSYNC=y -e
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/omapfbplay ${D}/${bindir}/omapfbplay-xv
+}