aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-08 09:24:33 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-08 09:24:33 +0200
commitfde8767cb80d192b8fb51d843a645f60fcd357ac (patch)
tree882bacf16c1b51bc179fc90c565a1de5b90dcbcf /recipes/ffmpeg
parent988f1e8aac6b7beb26ce0b10d496814bcf33c175 (diff)
downloadopenembedded-fde8767cb80d192b8fb51d843a645f60fcd357ac.tar.gz
ffmpeg git: bump SRCREV to get decode_video2 api
Diffstat (limited to 'recipes/ffmpeg')
-rw-r--r--recipes/ffmpeg/ffmpeg.inc2
-rw-r--r--recipes/ffmpeg/ffmpeg_git.bb12
2 files changed, 7 insertions, 7 deletions
diff --git a/recipes/ffmpeg/ffmpeg.inc b/recipes/ffmpeg/ffmpeg.inc
index 3f93765e45..7d7d957014 100644
--- a/recipes/ffmpeg/ffmpeg.inc
+++ b/recipes/ffmpeg/ffmpeg.inc
@@ -53,7 +53,7 @@ do_stage() {
for h in adler32.h avstring.h avutil.h base64.h bswap.h \
common.h crc.h fifo.h integer.h intfloat_readwrite.h \
- log.h lzo.h mathematics.h md5.h mem.h pixfmt.h random.h \
+ log.h lzo.h mathematics.h md5.h mem.h pixfmt.h random*.h \
rational.h sha1.h
do
install -m 0644 ${S}/libavutil/$h ${STAGING_INCDIR}/ffmpeg/$h
diff --git a/recipes/ffmpeg/ffmpeg_git.bb b/recipes/ffmpeg/ffmpeg_git.bb
index eaab7f5561..bc17596b77 100644
--- a/recipes/ffmpeg/ffmpeg_git.bb
+++ b/recipes/ffmpeg/ffmpeg_git.bb
@@ -3,17 +3,18 @@ require ffmpeg.inc
DEPENDS += "schroedinger libgsm"
PE = "1"
-PV = "0.4.9+${PR}+gitr${SRCREV}"
-PR = "r39"
+PV = "0.5.0+${PR}+gitr${SRCREV}"
+PR = "r0"
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_armv7a = "1"
-FFBRANCH_arm = "arm"
+#FFBRANCH_arm = "arm"
FFBRANCH ?= "master"
# When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
-SRCREV = "997df8779ce24088d0ebf77aa36f71280785a549"
-SRCREV_arm = "e4f37d7bc8ebd5e63ce57af157c2ebebfdf871fa"
+SRCREV = "d886804643d7427debfa70d824de7e53ae8e3e83"
+SRCREV_arm = "d886804643d7427debfa70d824de7e53ae8e3e83"
SRCREV_libswscale = "b2e1c8222eeef74b0ca8053b400957dd69e18e4d"
SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
"
@@ -47,7 +48,6 @@ EXTRA_OECONF = " \
--enable-libschroedinger \
--enable-libtheora \
--enable-libvorbis \
- --enable-swscale \
--arch=${TARGET_ARCH} \
--enable-cross-compile \
--extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \