summaryrefslogtreecommitdiffstats
path: root/recipes/fftw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fftw
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fftw')
-rw-r--r--recipes/fftw/benchfft_3.1.bb22
-rw-r--r--recipes/fftw/fftw.inc28
-rw-r--r--recipes/fftw/fftw_3.1.2.bb5
-rw-r--r--recipes/fftw/fftw_3.2.bb7
-rw-r--r--recipes/fftw/fftwf_3.1.2.bb4
-rw-r--r--recipes/fftw/fftwf_3.2.bb7
-rw-r--r--recipes/fftw/fftwl_3.1.2.bb5
-rw-r--r--recipes/fftw/fftwl_3.2.bb7
8 files changed, 85 insertions, 0 deletions
diff --git a/recipes/fftw/benchfft_3.1.bb b/recipes/fftw/benchfft_3.1.bb
new file mode 100644
index 0000000000..7b9a7110cf
--- /dev/null
+++ b/recipes/fftw/benchfft_3.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "FFTW benchmarks"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+# single precision fftw is called fftwf
+DEPENDS = "fftwf"
+
+SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz"
+
+EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ sed -i -e 's:all-recursive:$(RECURSIVE_TARGETS):g' ${S}/Makefile
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/recipes/fftw/fftw.inc b/recipes/fftw/fftw.inc
new file mode 100644
index 0000000000..acd1b27f4b
--- /dev/null
+++ b/recipes/fftw/fftw.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "FFTW"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RPROVIDES += "libfftw3"
+
+PR = "r1"
+
+SRC_URI = "http://www.fftw.org/fftw-${PV}.tar.gz"
+
+S = "${WORKDIR}/fftw-${PV}"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ echo 'AM_PROG_AS' >> ${S}/configure.ac
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+
+PACKAGES =+ "lib${PN}"
+
+FILES_lib${PN} = "${libdir}/lib*.so.*"
+
+# rename binary in /bin and use u-a tpo choose between different precision implementations?
diff --git a/recipes/fftw/fftw_3.1.2.bb b/recipes/fftw/fftw_3.1.2.bb
new file mode 100644
index 0000000000..bb58aac8e1
--- /dev/null
+++ b/recipes/fftw/fftw_3.1.2.bb
@@ -0,0 +1,5 @@
+require fftw.inc
+
+EXTRA_OECONF = "--disable-fortran --enable-shared"
+
+
diff --git a/recipes/fftw/fftw_3.2.bb b/recipes/fftw/fftw_3.2.bb
new file mode 100644
index 0000000000..3dac339151
--- /dev/null
+++ b/recipes/fftw/fftw_3.2.bb
@@ -0,0 +1,7 @@
+require fftw.inc
+
+SRC_URI = "http://www.fftw.org/fftw-${PV}.tar.gz"
+
+EXTRA_OECONF = "--disable-fortran --enable-shared"
+
+
diff --git a/recipes/fftw/fftwf_3.1.2.bb b/recipes/fftw/fftwf_3.1.2.bb
new file mode 100644
index 0000000000..a0bba2c968
--- /dev/null
+++ b/recipes/fftw/fftwf_3.1.2.bb
@@ -0,0 +1,4 @@
+require fftw.inc
+
+EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
+
diff --git a/recipes/fftw/fftwf_3.2.bb b/recipes/fftw/fftwf_3.2.bb
new file mode 100644
index 0000000000..5bc3134593
--- /dev/null
+++ b/recipes/fftw/fftwf_3.2.bb
@@ -0,0 +1,7 @@
+require fftw.inc
+
+SRC_URI = "http://www.fftw.org/fftw-${PV}.tar.gz"
+
+EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
+
+
diff --git a/recipes/fftw/fftwl_3.1.2.bb b/recipes/fftw/fftwl_3.1.2.bb
new file mode 100644
index 0000000000..9097d5f1bc
--- /dev/null
+++ b/recipes/fftw/fftwl_3.1.2.bb
@@ -0,0 +1,5 @@
+require fftw.inc
+
+EXTRA_OECONF = "--disable-fortran --enable-long-double --enable-shared"
+
+
diff --git a/recipes/fftw/fftwl_3.2.bb b/recipes/fftw/fftwl_3.2.bb
new file mode 100644
index 0000000000..31d0ed0b53
--- /dev/null
+++ b/recipes/fftw/fftwl_3.2.bb
@@ -0,0 +1,7 @@
+require fftw.inc
+
+SRC_URI = "http://www.fftw.org/fftw-${PV}.tar.gz"
+
+EXTRA_OECONF = "--disable-fortran --enable-long-double --enable-shared"
+
+