aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/file/file_4.18.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/file/file_4.18.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/file/file_4.18.bb')
-rw-r--r--recipes/file/file_4.18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/file/file_4.18.bb b/recipes/file/file_4.18.bb
new file mode 100644
index 0000000000..a98c68009e
--- /dev/null
+++ b/recipes/file/file_4.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ file://dump \
+ file://filesystems"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+ cp ${WORKDIR}/dump ${S}/magic/Magdir/
+ cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
+}
+
+do_stage() {
+ autotools_stage_all
+}