aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/firmwares
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-09-08 11:37:44 -0400
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-09-08 17:49:53 +0200
commite9ee201981bbdb939bd1c4081962dff3f118167c (patch)
treef086e2a47f69761904df236f0dbb85e90d35384b /recipes/firmwares
parent0617b085eb3f10f8aa5ee5957fbf9c0b45fb596f (diff)
downloadopenembedded-e9ee201981bbdb939bd1c4081962dff3f118167c.tar.gz
marvel-sdio-fw: added firmware for WiFi powered BUGBase
Diffstat (limited to 'recipes/firmwares')
-rw-r--r--recipes/firmwares/files/Marvell-Licence.txt (renamed from recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt)0
-rw-r--r--recipes/firmwares/marvell-sdio-fw/9.70.3-p37.tar.gzbin0 -> 88003 bytes
-rw-r--r--recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb19
3 files changed, 19 insertions, 0 deletions
diff --git a/recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt b/recipes/firmwares/files/Marvell-Licence.txt
index 87035b055a..87035b055a 100644
--- a/recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt
+++ b/recipes/firmwares/files/Marvell-Licence.txt
diff --git a/recipes/firmwares/marvell-sdio-fw/9.70.3-p37.tar.gz b/recipes/firmwares/marvell-sdio-fw/9.70.3-p37.tar.gz
new file mode 100644
index 0000000000..3efd73fdb5
--- /dev/null
+++ b/recipes/firmwares/marvell-sdio-fw/9.70.3-p37.tar.gz
Binary files differ
diff --git a/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb b/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb
new file mode 100644
index 0000000000..c3ccaf78c5
--- /dev/null
+++ b/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
+LICENCE = "closed"
+
+SRC_URI = "file://${PV}.tar.gz \
+ file://Marvell-Licence.txt"
+
+S = "${WORKDIR}/${PV}/FwImage"
+
+do_install() {
+
+ install -d ${D}${base_libdir}/firmware
+ install -m 0644 sd8686.bin sd8686_helper.bin ${D}${base_libdir}/firmware
+ install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"