aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/firmwares
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-07-15 07:05:27 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-07-16 16:24:20 +0200
commit098fdd2516376187580f413c96780ce879d673e3 (patch)
treecb22d7305384cd91f79793c79e010f1ee757bfa9 /recipes/firmwares
parent145cb3f5d649181631493a3923cfbceed647297a (diff)
downloadopenembedded-098fdd2516376187580f413c96780ce879d673e3.tar.gz
marvell-gspi and marvell-sdio: move duplicated license in separate package/recipe
Before moving the license we had: Collected errors: * check_data_file_clashes: Package marvell-sdio-fw wants to install file .../rootfs/x11-sato2-image/lib/firmware/Marvell-Licence.txt But that file is already provided by package * marvell-gspi-fw * opkg_install_cmd: Cannot install package task-base-extended. in do_rootfs for machine bug under angstrom. In bug.conf there is: MACHINE_EXTRA_RRECOMMENDS = "marvell-gspi-fw marvell-sdio-fw kernel-modules" That installed both marvell-gspi-fw and marvell-sdio-fw each recipe had the same firmware license file(Marvell-Licence.txt) The two identic license files were installed at the same location which led to the install issue mentioned above. Moving the license in its own recipe/package removes the clash. In order to fullfill the legal requirements of the license I used RDEPENDS in order to be shure that the license would be present if at least one of the firmwares are present
Diffstat (limited to 'recipes/firmwares')
-rw-r--r--recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb6
-rw-r--r--recipes/firmwares/marvell-license_9.70.3-p37.bb17
-rw-r--r--recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb8
3 files changed, 25 insertions, 6 deletions
diff --git a/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb b/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb
index 736ddb8e0e..bee8fc6c7c 100644
--- a/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb
+++ b/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb
@@ -1,8 +1,9 @@
DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
LICENCE = "closed"
-SRC_URI = "file://${PV}.tar.gz \
- file://Marvell-Licence.txt"
+SRC_URI = "file://${PV}.tar.gz"
+
+PR="r1"
S = "${WORKDIR}/${PV}/FwImage"
@@ -10,7 +11,6 @@ do_install() {
install -d ${D}${base_libdir}/firmware
install -m 0644 gspi8686.bin helper_gspi.bin ${D}${base_libdir}/firmware
- install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
ln -s helper_gspi.bin ${D}${base_libdir}/firmware/gspi8686_hlp.bin
}
diff --git a/recipes/firmwares/marvell-license_9.70.3-p37.bb b/recipes/firmwares/marvell-license_9.70.3-p37.bb
new file mode 100644
index 0000000000..a72d8205ad
--- /dev/null
+++ b/recipes/firmwares/marvell-license_9.70.3-p37.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "License for Marvel 8686 wifi chipsets"
+LICENCE = "closed"
+
+SRC_URI = "file://Marvell-Licence.txt"
+
+RDEPENDS_${PN} += "marvell-license"
+
+do_install() {
+
+ install -d ${D}${base_libdir}/firmware
+ install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"
diff --git a/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb b/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb
index c3ccaf78c5..f0b44b78f1 100644
--- a/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb
+++ b/recipes/firmwares/marvell-sdio-fw_9.70.3-p37.bb
@@ -1,8 +1,11 @@
DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
LICENCE = "closed"
-SRC_URI = "file://${PV}.tar.gz \
- file://Marvell-Licence.txt"
+SRC_URI = "file://${PV}.tar.gz"
+
+PR = "r1"
+
+RDEPENDS_${PN} += "marvell-license"
S = "${WORKDIR}/${PV}/FwImage"
@@ -10,7 +13,6 @@ do_install() {
install -d ${D}${base_libdir}/firmware
install -m 0644 sd8686.bin sd8686_helper.bin ${D}${base_libdir}/firmware
- install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
}
PACKAGES = "${PN}"