aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/firmwares
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-07 14:10:37 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-07 14:12:38 +0200
commit6859fd82cd4cd53a04bfd684b1ab03a28b4c2ea0 (patch)
treec0cb2d576c8e71696db3f6521fe4dcecd8fdbf8c /recipes/firmwares
parent9f4743e9692fba77d058e79bb2fef2decea1588a (diff)
downloadopenembedded-6859fd82cd4cd53a04bfd684b1ab03a28b4c2ea0.tar.gz
firmware-ti-wl1251: new recipe
Diffstat (limited to 'recipes/firmwares')
-rw-r--r--recipes/firmwares/firmware-ti-wl1251.bb21
-rw-r--r--recipes/firmwares/firmware-ti-wl1251/README9
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes/firmwares/firmware-ti-wl1251.bb b/recipes/firmwares/firmware-ti-wl1251.bb
new file mode 100644
index 0000000000..dd374b8e9d
--- /dev/null
+++ b/recipes/firmwares/firmware-ti-wl1251.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Firmware for Texas Instruments WL1251 wifi chipset"
+LICENCE = "closed"
+
+SRC_URI = "file://*"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware
+ install -m 0644 README ${D}${base_libdir}/firmware/README.ti-wl1251
+ for file in wl1251-fw.bin wl1251-nvs.bin
+ do
+ if test -e $file; then install -m 0644 $file ${D}${base_libdir}/firmware; fi
+ done
+}
+
+# NOTE: This package is an empty stub, see firmware-ti-wl1251/README
+ALLOW_EMPTY = "1"
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"
diff --git a/recipes/firmwares/firmware-ti-wl1251/README b/recipes/firmwares/firmware-ti-wl1251/README
new file mode 100644
index 0000000000..8a5522e31f
--- /dev/null
+++ b/recipes/firmwares/firmware-ti-wl1251/README
@@ -0,0 +1,9 @@
+TI WL1251 firmware is not redistributable. Please download from your device.
+You need the following files, which should reside in /etc/firmware or /lib/firmware.
+ * wl1251-fw.bin (firmware)
+ * wl1251-nvs.bin (calibration data)
+Note that the calibration data is device specific, so you are not supposed
+to just grab it from any location but your device.
+
+:M:
+