aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flac
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-15 18:45:17 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-15 18:46:35 +0100
commitc719c6c1857ec724e7f90f0e475b1e7c84020ef5 (patch)
treeeaa2f8c81a887bf87a8c266746f9e7e20d955e79 /recipes/flac
parent5f3bc5b423e00089e97c7a1657760f67bf20aa34 (diff)
downloadopenembedded-c719c6c1857ec724e7f90f0e475b1e7c84020ef5.tar.gz
flac: fix build problems with rpath on older libtool
* bump INC_PR
Diffstat (limited to 'recipes/flac')
-rw-r--r--recipes/flac/flac.inc8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/flac/flac.inc b/recipes/flac/flac.inc
index 15a8d040fe..2b35d641e4 100644
--- a/recipes/flac/flac.inc
+++ b/recipes/flac/flac.inc
@@ -7,7 +7,7 @@ DEPENDS = "libogg"
SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
file://xmms.m4"
-INC_PR = "r1"
+INC_PR = "r2"
inherit autotools gettext
@@ -18,7 +18,8 @@ EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
--without-xmms-prefix \
--without-xmms-exec-prefix \
--without-libiconv-prefix \
- --without-id3lib"
+ --without-id3lib \
+ "
do_configure () {
install -d ${S}/m4
@@ -27,6 +28,9 @@ do_configure () {
# removes '-read-only-relocs' which is enabled for PowerPC builds.
# It makes the build fail, other archs are not affected. Fixes #1775.
sed -i 's/-Wl,-read_only_relocs,warning//g' src/libFLAC/Makefile
+ # use same fix as libiconv
+ sed -i -e s/^hardcode_libdir_flag_spec/#hardcode_libdir_flag_spec/ \
+ -e s/^runpath_var/#runpath_var/ ${S}/*-libtool
}
PACKAGES += "libflac libflac++ liboggflac liboggflac++"