aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flashrom
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/flashrom
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/flashrom')
-rw-r--r--recipes/flashrom/files/makefile-disable-strip.patch18
-rw-r--r--recipes/flashrom/flashrom_svn.bb21
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/flashrom/files/makefile-disable-strip.patch b/recipes/flashrom/files/makefile-disable-strip.patch
new file mode 100644
index 0000000000..0296e1d99e
--- /dev/null
+++ b/recipes/flashrom/files/makefile-disable-strip.patch
@@ -0,0 +1,18 @@
+--- flashrom/Makefile.orig 2008-10-25 12:13:21.000000000 +0300
++++ flashrom/Makefile 2008-10-25 12:14:04.000000000 +0300
+@@ -17,7 +17,6 @@
+ LDFLAGS = -lpci -lz
+ else
+ LDFLAGS = -lpci -lz
+-STRIP_ARGS = -s
+ endif
+ ifeq ($(OS_ARCH), FreeBSD)
+ CFLAGS += -I/usr/local/include
+@@ -40,7 +39,6 @@
+
+ $(PROGRAM): $(OBJS)
+ $(CC) -o $(PROGRAM) $(OBJS) $(LDFLAGS)
+- $(STRIP) $(STRIP_ARGS) $(PROGRAM)
+
+ flashrom.o: flashrom.c
+ $(CC) -c $(CFLAGS) $(SVNDEF) $(CPPFLAGS) $< -o $@
diff --git a/recipes/flashrom/flashrom_svn.bb b/recipes/flashrom/flashrom_svn.bb
new file mode 100644
index 0000000000..0c51a5857e
--- /dev/null
+++ b/recipes/flashrom/flashrom_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Flashrom is a simple utility for reading/writing BIOS chips"
+HOMEPAGE = "http://www.coreboot.org/Flashrom"
+LICENSE = "GPL"
+DEPENDS = "zlib pciutils"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = " \
+ svn://coreboot.org/repos/trunk/util/;module=flashrom \
+ file://makefile-disable-strip.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/${PN}"
+
+LDFLAGS += "-lpci -lz"
+
+do_install () {
+ install -d "${D}${sbindir}"
+ oe_runmake 'PREFIX=${D}/${prefix}' install
+}